Jetson Orin Nano - dead on arrival + SDK flashing problem

Hi.

I purchased Jetson Orin Nano during GTC, but the board is dead when plugged in. Just writing it here to help you and to let you know it’s a total hassle to make it work. Everything below is done from Ubuntu 22.04.3 on a T14 Lenovo PC laptop.

The first step customer must do is to record the SD disk image from the laptop into the SD card. Image I took from the website https://developer.nvidia.com/embedded/learn/get-started-jetson-orin-nano-devkit#write, but booting doesn’t result in anything (black screen, no Ethernet LEDs are active).

Reading Amazon reviews where people got a dead board upon arrival too, I’m assuming that flashing is required. Steps I followed with the hardware setup:

  • SD card in Orin module
  • 512GB NVM module plugged into Orin dev kit
  • USB keyboard connected
  • screen connected
  • USB-C connected to T14
  • Ethernet cable connected to T14 directly OR to a Eero access point (via wired port) directly, where my DHCP server is

I get the board into recovery mode and start the SDKManager 2.1.0.11660. The board gets detected and flashing works OK until approx: 88%-91%, and then dies.

23:19:10 INFO: Flash Jetson Linux - flash: Waiting for target to boot-up...
23:19:11 INFO: Flash Jetson Linux - flash: Waiting for target to boot-up...
23:19:24 INFO: Flash Jetson Linux - flash: Waiting for device to expose ssh ...RTNETLINK answers: File exists
23:19:24 INFO: Flash Jetson Linux - flash: RTNETLINK answers: File exists
23:19:24 INFO: Flash Jetson Linux - flash: Waiting for device to expose ssh ... Run command: flash on fc00:1:1:0::2
23:19:24 INFO: Flash Jetson Linux - flash: SSH ready
23:19:24 INFO: Flash Jetson Linux - flash: mount.nfs: access denied by server while mounting [fc00:1:1:0::1]:/home/wkoszek/nvid ia/nvidia_sdk/JetPack_6.0_DP_Linux_DP_JETSON_ORIN_NANO_TARGETS/Linux_for_Tegra/rootfs
23:19:24 INFO: Flash Jetson Linux - flash: Cleaning up...
23:19:24
ERROR: Flash Jetson Linux - flash: command terminated with error
23:19:24
SUMMARY: DateTime Target Setup - target: Depends on failed component

I don’t understand why it’s trying to NFS mount from IPv6. This is a little crazy. The Ethernet, overall, starts to blink at some point during the flashing process, but from the external point of view the Ethernet appears dead → the interface never configured itself from DHCP (no Eero notification about the new device)

I tried several experiments, all resulting in this ^^^ failure:

  • flashing in Pre-Config mode to SD → fail
  • flashing in Pre-Config mode to NVMe → fail
  • flashing in Runtime mode to SD → fail
  • flashing in Runtime mode to NVMe → fail

Is there any fool-proof way to unbrick this board?

You can do

sudo ./flash.sh jetson-orin-nano-devkit internal

under Linux_for_Tegra to flash into the SD card.

OK. That worked. Thanks!

Dave, I think you guys should just have SDKManager call this command instead of whatever it’s calling now. Whatever is there now is totally broken.

Can I now somehow flash the NVMe? I’d like the system to use NVMe.

NO, we won’t.

I won’t really go in to the detail, but for OTA to work with Jetson devices, the regular way to flash them is using SDK Manager/initrd flash, and flash.sh for SD card is only a convenient way for development, but not the regular/recommended way.

Please solve the NFS mount error yourself; our tool relies on NFS so rootfs on host PC can be accessed by the device.

Solve the NFS mount error, or you can do:

sudo ./flash.sh jetson-orin-nano-devkit-nvme internal

Ok. I’ll try flashing NVMe from “flash.sh”

The NFS problem – it’s something that SDKManager is attempting to do itself. I have no idea what it’s trying to do nor why it doesn’t work. Is this documented somewhere?

NO, we use NFS for flashing but this tool is not written by us.

Ok. Fair enough. Just to let you know – the Ethernet appears pretty dead before thismount_nfs step. I can’t seem to see any activity from the board – it doesn’t appear to be sending any DHCP requests etc. I’m not surprised it’s not mounting, because I have a feeing that the interface on the board doesn’t have the IP at all.

We are talking about stuff on the host PC, not on Jetson.

Ah. Ok. So sounds like you’re saying that to properly flash with the SDKManager, people need to enable NFS themselves?

Our flashing script only tries to mount the folder via NFS, but if the NFS system service is not even active/running on your host PC, of course it fails.
Or it’s usually some permission issues like shown in the link above.

NFS mount through the network over USB interface so it is unrelated to the ethernet port. Please check your firewall setting or disable VPN before flashing. The NFS server is started by the flashing script so you should not have to do anything.

That makes more sense. Firewall settings:

ufw status gives me Status: inactive.

If you guys care about fixing it, maybe SDKManager should run ping or other type of a smoke test?

If you want me to help you, send me the diagnostics command you want me to run. I could try plugging in an empty SD card and re-reunning the flashing process again.

Thank you! If you don’t mind can you run

ls -la /home/wkoszek/nvidia/nvidia_sdk/JetPack_6.0_DP_Linux_DP_JETSON_ORIN_NANO_TARGETS/Linux_for_Tegra
showmount -e
sudo systemctl status nfs-kernel-server
sudo blkid
df -h

Ok, this is just the stuff from the laptop for now, no board attached:

The first time I flashed my phone, I was prompted to enter a password of ssh to connect to the host. I entered it incorrectly and had to start from scratch. The second time, I did not have the opportunity to enter the ssh password, but instead ssh ready, and then the nfs mount failed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.