Flash fails on Jetson Orin Nano

Using SDKManager with brand new Orin Nano. It does boot into recovery mode when jumpered, and it is recognized by the software, and all the downloads are successful. I am configuring it for manual, Runtime, and SDcard (with newly formatted sdcard). But the flashing of fails every time.

There are lots of errors in the logs, and when it’s done there does seem to be a boot image on the SDcard, but when booted (without the jumper) I see the BIOS/config screen then it goes blank screen.

Got sidetracked with initial errors about “failed to read rcm_state” and “Skip generating mem_bct because sdram_config is not defined” and “value 0x31 is out of range”, but maybe those are spurious?

Tried different USB cables, various USB ports, etc. Always the same.

Here’s the logs, help anyone? Thanks.
SDKM_logs_JetPack_6.0_DP_Linux_for_Jetson_Orin_Nano_modules_2024-03-25_14-59-08.zip (480.8 KB)

Just do

sudo ./flash.sh jetson-orin-nano-devkit internal

under /home/paulspudis/nvidia/nvidia_sdk/JetPack_6.0_DP_Linux_DP_JETSON_ORIN_NANO_TARGETS/Linux_for_Tegra.

That fails too.

flash-raw.log (9.1 KB)

[ 0.5360 ] Sending bct_br
[ 0.7030 ] ERROR: might be timeout in USB write.
Error: Return value 3


Ok, got it working. What I know:

I could not get the flashing to work through the SDKManager GUI, and I tried a lot.
What worked was running “sudo ./flash.sh jetson-orin-nano-devkit internal” directly.
That would also fail if it was run after the GUI failed: you had to recycle the power.
When you first boot with the jumper in for recovery mode, the USB has ID:0955:7035.
After running the GUI and failing, it has 0955:7523, and which fails with “flash.sh”.
After successfully flashing and booting linux, it has the value:0955:7020.
You don’t have to remove the pin while flashing, it only has an effect on bootup.

Note that I was only flashing to a SDcard, I didn’t try the USB or NVMe options.

Summary of how to install successfully:

  1. Jumper the pins and boot it with USB attached and a formatted SDcard installed.
  2. Use the GUI to download and install all of the files, then try to flash it.
  3. If that fails, then recycle the power to the Nano, and verify the correct ID.
  4. Run the “flash.sh” script manually.

I did discover another potential issue. Python must be installed, and in fact there must be a “python” command as well as a “python3” command. This is because both are used in the scripts. This was true on one of our servers, but not another, so I had to alias “python” to “python3”.

I have taken a look at your SDKM log. Do you have a firewall or VPN running while flashing? Flashing USB and NVMe requires the use of a NFS server so make sure your firewall allow that.

I am flashing SDcard, not USB or NVMe. But that’s good info, thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.