Jetson Orin Nano doesn't show up with lsusb

Hi,

I’m trying out the Jetson Orin Nano Developer Kit for the first time. My problem is I could not find the board using the “lsusb” command.

I tried the method To Determine Whether the Developer Kit Is in Force Recovery Mode

Unfortunately, I’m still unable to detect the board.

These are the system information:

  • Host PC: Ubuntu 22.04.4 LTS
  • Board Model: NVIDIA Jetson Orin Nano 8GB Module

Please let me know if I’m missing any information.

Thanks!

Do you connect a jumper on the FRC pin already? Or you don’t know what I am talking about?

Recovery mode needs to connect specific pin to get it enabled.

I tried connecting pins 9 and 10 with a jumper.

Is your usb cable a fine one?

Yes, I tried with multiple USB cables.

Is your host machine a VM?

No, it’s a Lenovo laptop with Ubuntu 22.04.

Could you share a photo of your usb connection and your jumper location?

Sure, here’s how I connect the USB and jumper.

You put the jumper in wrong location. There is another 12 pin header under the module.

1 Like

Is it the right location?

Yes,

  1. remove the power cable

  2. short REC and GND pins

  3. plug in the power cable (device shall power up)

  4. connect the type C cable and check lsusb.

Thank you for your fast response. I’ll give it a go and get back with the update ASAP.

@WayneWWW After connecting the jumper in the right direction now I can see the device with “lsusb”. Thank you very much for your support. :)

1 Like

Please remember to remove the jumper after you flash the board.

1 Like

Noted.

@WayneWWW As per your suggestion now I’m able to detect the device. However, while trying to flash the board using the SDKManager, I’m getting some errors. I’m not sure what’s wrong so I exported the log files and attached here for your review.

Can you please check and suggest what should I do next?
SDKM_logs_JetPack_6.0_DP_Linux_for_Jetson_Orin_Nano_modules_2024-03-14_10-27-57.zip (202.1 KB)

The flash process stops at a weird point. Is this a fresh Orin nano devkit? I mean does anyone else ever flash or use it before?

The devkit is new and original but it was used before.

Is it still able to boot up? as it didn’t get flashed yet