Forceware 257.21 == OpenCL broken

I’ve migrated from FW 197.45 to 257.21 and my OpenCL program no longer works ( returns a mysterious CL_INVALID_BINARY error on clBuildProgram or acts strangely ).
I call clBuildProgram with these options:

-cl-fast-relaxed-math -cl-nv-verbose -DOPENCL_NVIDIA

and the program has 8 kernel functions.

The fist time my program is executed is Ok and the verbose log is coherent ( outputs # of registers used, etc…). The second time the app runs, the verbose log just contains this:

“Considering profile ‘compute_12’ for gpu=‘sm_12’ in ‘cuModuleLoadDataEx_4’”
( no info about registers or other data is retrieved )
Then, the program generates thrash output. Only works well the first time.

It’s like if you were using some kind of “binary blob” file cache and you weren’t cleaning or hashing it correctly…

With the previous 197.45 all works perfectly.
Pls, fix it.

I use Win7 x64, FW 257.21 WHQL and a GT 240.
thx

i had the same problem after migrating from 195.xx to 2xx.xx. while i still have other errors, recompiling my kernels on a system with an installed FW 2xx.xx solved at least the CL_INVALID_BINARY error.

Yep, but those drivers just execute my kernels as no-ops. They finish immediatly without performing any computation ( without any error btw ).

Any idea when they’re going to be fixed pls? The 197 works ok!

Any new when this is going to be fixed, pls?

Yeah, the new drivers have a lot of things that are broken in OpenCL 1.1. Even constant memory is broken.

Yep, but the curious thing is that I’m using OpenCL 1.0 :teehee:

Oh yeah? Well I’m having the same problem, and I’m not even using OpenCL!

http://forums.nvidia.com/index.php?showtop…uleLoadDataEx_4

I’ve tried the new 258.96 and they have the same problem :(
My complex kernel just returns zero values.