opencl on driver v195.17 does Opencl woirk on the latest driver release !??

I had some problems with runing OpenCl on the newwest version of NVIDIA driver - 195.17 ??

the code throws outsyptic error #-1 during bulding the program…??

the same works fine with the earlier driver version - 190.29

any help would be much appreciated??


I am running 195.30 on linux. What errors are you having while building the program? There are certain changes with the 195 drivers though, like it was pointed out to by Big_Mac_ here…mp;#entry979817


clBuildProgram was throwing at the cryptic error#-1

this was apparently because of one of the arguments to the kernel, which was not a pointer had a address space specifier (__global)

The weird part, which i don’t understand is that this worked perfectly fine with the older driver (v190.29) ??

any reasons as to why ??

Without going into the details of how you specified the kernel arg, the 190.29 accepted many things that were wrong. 195.xx seems to have solved a lot of my issues.

the kernel is somewhat like -

__kernel my_kernel (__global int * myarr1, __global int* myarr2, __global int var1)

So, the '__global" address space specifier for var1 - was the culprit

the above kernel declaration worked on the 190.29, but throws out an error on the 195.17 !!

changing it to -

__kernel my_kernel (__global int * myarr1, __global int* myarr2, int var1)

works fine !!