GALAX 3090 with NVLINK not detected

Hi Sir,

I have tried many driver for x2pcs 3090 from GALAX with NVLINK.

However, I cannot get the SLI option to be shown in control panel

I am using Asus Proart Z790 and checked that The GPU are runing at PCIe x8 Gen 4.

Can any help advise me how to enable this NVLINK for acceleration the GPU.

Best regards,
Narudol T.

Hi there @user130852 and welcome to the NVIDIA developer forums!

Did you make sure that the NVLINK (former SLI) bridge is connected properly on both cards? That would be the first thing that comes to my mind now. Also make sure to have the latest BIOS update on the board.

Hello, any updates to this issue? Did you get it working?

I’m having the exact same issue after upgrading to this motherboard. It worked just fine with my old board, but with the new one there is no setting options in the nvidia control panel.

I’m on the latest BIOS, pcie lanes are set to 8x/8x. I’ve reseated the NVLink twice, installed 3 different versions of the studio driver to see if an older one would work, and plugged and swapped in multiple displays to both GPUs to see if that would get it to work.

I also noticed in VRay that under GPU load it stays at 0% on both cards even when they are running full tilt on a render.

Any other suggestions, as I’m running out of ideas. I need the ability to pool memory for large scale projects. Already running out of vram even with the 24GB 3090ti’s.

No I am still cannot use this NVLINK bridge as well, and NVIDIA team also not answer !!!

Well, for what it’s worth, I did reply a while ago, you might not have seen my post.

And welcome to the NVIDIA developer forums @03-scars-kennel.

On checking the specs a bit closer it seems the Z790 does not support SLI anymore. Since the end-user NVLINK support was discontinued, Motherboard manufacturers also stopped adding SLI support on their products.

Pooling VRAM on GPUs will still be possible through the PCIe bus, but only through CUDA or Vulkan applications with dedicated mulit-GPU support.


I use VRAY for GPU rendering and they only support memory pooling through NVLINK to my knowledge.

I only need NVLINK to work not SLI. Is there no workaround for this? It seems kind of outrageous that this support would be dropped for NVLINK so quickly. The physical hardware should be there on the motherboard as there are plenty of pcie lanes available. Is this a licensing issue or something now? Is there anyway to “trick” the nvidia drivers into allowing NVLINK? Or am I just out of luck for now and have to downgrade to my last gen motherboard and CPU?

I think you are correct, looking at the FAQ on the V-Ray site they list SLI-ready Motherboards as a requirement.

But if you look at older news regarding SLI you will see that NVIDIA already phased this out in 2020 when it was announced that driver support for SLI would be dropped and games (or applications) would need to implement any SLI support by themselves. And 3090 was the last consumer GPU still enabling a physical SLI/NVLINK bridge.

NVLINK is an improved version of SLI based on the same principles but with focus on enterprise applications. Our workstation and server GPUs will continue to support NVLINK. See NVLink & NVSwitch: Fastest HPC Data Center Platform | NVIDIA

I hope you understand that I cannot disclose any business reasons or other details on NVLINK.
There is also, to my knowledge, no way to re-enable this functionality on new consumer HW.

I am sorry for any inconvenience this causes.