Geforce 600 Kepler users caution with driver 470 (Nvidia has done a wrong act .. not is about drop support in driver 480 )

After a long support Nvidia will drop support to all Kepler GPUs in driver 480.
What is the problem ?
Problem is driver 470 was added CUDA 11.4.
Using Ubuntu 20.04.3 and 21.04 GT 640 driver 470.
Not is possible use CUDA or NVENC … softwares crash or freeze and also issues with softwares trying use OpenGL 32 bits.

Nvidia will drop support with a version for Kepler with issues ?
Nvidia need fix it and create a fix in next 470 driver doing go back CUDA 11.3 and CUDA 11.4 only in 11.3.

Anyone known if is possible use driver 470 using CUDA 11.3 ?
Nvidia has done a problem for Kepler GPUs in 470.

Driver 465.31 runs perfectly without issues.
Thanks for your reply.

Read the documentation before spewing nonsense.

NVIDIA will be providing security and bug fixes to your GPU till 2024 via the R470 LTSB branch.

That’s Ubuntu’s problem. Try using a distro like Fedora or Manjaro.

Only confirmed issue is the GSync issue, nothing else.

“Read the documentation before spewing nonsense. Only confirmed issue is the GSync issue, nothing else.”

Read after any information before invaliding a correct post.

KEPLER NOT IS COMPATIBLE WITH CUDA 11.4

https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html

“That’s Ubuntu’s problem. Try using a distro like Fedora or Manjaro.”
Nothing related with Ubuntu.

Have another problem happening when installing both nvidia driver binary and Ubuntu metapackage breaking opengl x86.

My topic was correct because is problem done by Nvidia.
The correct is CUDA 11.4 in driver 480.
If driver 470 is last supported for Kepler thus the correct is Nvidia fixing returning CUDA 11.3 in next 470 fix.

Oh yes … Kepler users contact Nvidia for fix it.

And? What do you want them to do? Withdraw features from CUDA 11.4, holding all GPUs back just so a decade old architecture can use it? Be grateful NVIDIA is providing security bug fixes,don’t expect them to hold back progress for Kepler.

See if your problems occur on a distro that doesn’t believe in the “out of date means stability” philosophy. Boot up a Manjaro stick and select proprietary drivers, if everything works fine there then go complain to Ubuntu.

CUDA 11.4 had to be released only in driver 480.
Now Kepler users using last driver version not being possible use CUDA and NVENC and more worst future fix will be useless if not fixed it.
Go back CUDA 11.3 is the correct because today the truth last driver for Kepler is 465

Learn correct grammar and how to form a sentence. I can’t understand you.

CUDA is not released with the driver. nvidia-smi shows the max supported version. You can always use an older version of CUDA with a newer driver.

@ Mart
Thanks for reply.
Driver 470 install CUDA 11.4 that not is compatible with Kepler.
I not wait Nvidia adding CUDA 11.4 features in 11.3 for Kepler or any other thing.
I wait Nvidia releasing the last driver compatible with Kepler installing CUDA 11.3.
Not issues with OS. The softwares crash because is installed CUDA 11.4.
How install current driver version and return to CUDA 11.3 ?

Don’t install all of cuda. Install the driver (from you distribution), then install just cuda-toolkit 11.3.

@ Mart
Thanks for your reply.
Installing driver from distro CUDA 11.4 is installed automatically not having command line for user choice if disable it.
In other hand official driver also install CUDA 11.3 and not have command line to disable it.
Well … I will try install SDK 11.3

Never heard of a distro installing full cuda just with the driver. Which would that be?

The essential files are installed.
nvenc encode decode and compute libraries.
CUDA SDK not is installed.

Nvidia need fix that problem. The correct is driver 470 having CUDA 11.3 thus avoiding problems for users.
CUDA 11.4 only in driver 480.
Kepler need the last driver plus a CUDA SDK ??? I only need the libraries to run some softwares.
Now users need fix it ?

I meant which distro are you using…

Ubuntu 20.04.3 and 21.04

Ok, I looked it up for you… next time read the docs for yourself!
https://docs.nvidia.com/cuda/cuda-toolkit-release-notes/index.html#cuda-major-component-versions__table-cuda-toolkit-driver-versions

Here you can see the min/max needed/supported driver versions.

So I suggest you purge/uninstall all of cuda and the driver before this:

sudo apt install nvidia-driver-470
Then go and read this:
https://docs.nvidia.com/cuda/archive/11.3.1/cuda-installation-guide-linux/index.html#ubuntu-installation
follow the guide until you are instructed to install cuda.
BUT instead of this command:
sudo apt-get install cuda

YOU DO:
sudo apt-get install cuda-toolkit

You is trying help me … thanks , but not is exactly the main because of topic.

Nvidia driver install libraries (compute , decode and encode files) related with CUDA and NVENC.

In a Ubuntu 20.04.3 or 21.04 with Kepler :

  • If user install driver 465 only need .run package or distro package and simply all (OpenGL, Vulkan, CUDA and NVENC) works without issues.
  • If user install driver 470 only works OpenGL and Vulkan. Not support for CUDA and NVENC for Kepler. .run package not has any command to disable install cuda libraries. Distro allow install only the driver. Thus the user need figure how use current driver and downgrade for CUDA 11.3. Not is a good option for all users, but nothing was done to fix it.

Thus the users need figure and install driver and after a CUDA SDk ?

See the example.
Now trying use the commands from link
https://docs.nvidia.com/cuda/archive/11.3.1/cuda-installation-guide-linux/index.html#post-installation-actions
and not works !
The user wait a fix thus search information being much details not fix.
The user seeing only searching in Ubuntu repository the name “CUDA” is listed several package being one “nvidia-cuda-toolkit (10.1.243-3)”.
The user only will see what is CUDA version from package nvidia-cuda-toolkit (10.1.243-3) when installing and big chance that is a old version that after does problems to remove ?

You are understanding my topic ?
CUDA 11.3 works with driver 470.
Nvidia simply return CUDA 11.3 in driver 470 update thus fixing the problem and avoiding the problems above for all users.
That is problem created and Nvidia need fix it.

Thanks for your reply with all install information. I had tested only installing using driver files and not installing any file named “encode-decode-compute” and had worked only if installing the files version for 460.

I think you still don’t get it.
If you install the full cuda from nvidia website, it will install the driver.
You need to do it the other way round. Install the driver from your distro package and then install cuda-toolkit (version of your choice and compatible list) from nvidia.

Thanks for your reply.
Yes I had information about how install from nvidia or distro , but is a “fix” and after more others problems to fix.

See another problem.
Installing only using the distro driver and after the CUDA toolkit.
A file of size 2,82 GB to try fix it ! and another detail installing will use a huge disk space used.
More another problem ! Installing CUDA toolkit also install compatible NVENC ? Need install decode and encode files ?
The user need figure information to fix a problem created by Nvidia.

Problem even.
I want to use nvidia run package and not doing all above.
Nvidia not fixing the installer is not sense more yet because distro use files from nvidia binary run package thus Nvidia fixing that problem also fix problem in distro driver.

apt depends nvidia-driver-470

Depends: libnvidia-decode-470
Depends: libnvidia-encode-470

Ok, then wait for nvidia to provide packages for every linux distribution available - good luck!

@ Mart
Not waiting a run package for each distro ,but fix in run package.
Distro use that run package and does some changes and repack in own package format.
If Nvidia fix binary all files in distro package also will be fixed.

I had tested and the files are
libnvidia-common-470_470.63.01-0ubuntu0.20.04.2_all.deb
libnvidia-compute-470_470.63.01-0ubuntu0.20.04.2_amd64.deb
libnvidia-compute-470_470.63.01-0ubuntu0.20.04.2_i386.deb
libnvidia-decode-470_470.63.01-0ubuntu0.20.04.2_amd64.deb
libnvidia-decode-470_470.63.01-0ubuntu0.20.04.2_i386.deb
libnvidia-encode-470_470.63.01-0ubuntu0.20.04.2_amd64.deb
libnvidia-encode-470_470.63.01-0ubuntu0.20.04.2_i386.deb

Look how a “better” fix than download CUDA SDK.