470.14 - WSL with W10 Build 21343 - NVIDIA-SMI error

Is nvidia-smi broken? I’m on an AMD build with 2060 Super. Windows Insider 21343 (updated today) and 470.14.

Ubuntu 20.04, CUDA toolkit 11.2 installed using the WSL shell script that does not install Linux drivers.

I copied nvidia-sma to /usr/bin as instructed. When run, I get:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Failed to properly shut down NVML: Driver Not Loaded

6 Likes

Yeah, it’s the same with me.
Anyone can help?

2 Likes

I have the same issue. Ubuntu 20.04, CUDA 11.2, Windows 21343.1000, 5.4.72-microsoft-standard-WSL2 kernel. I’ve tried reinstalling CUDA.

2 Likes

Yep, same issue.

  • RTX 3060, drivers 470.14
  • Windows Insider 21343
  • Ubuntu 18.04 LTS,
  • Tried CUDA Toolkit 11.1.1 and CUDA Toolkit 11.2
    I followed this tutorial: CUDA on WSL :: CUDA Toolkit Documentation, BlackScholes sample works fine - no errors, but
    nvidia-smi or sudo docker run --rm --gpus all nvidia/cuda:11.1-base nvidia-smi returns:
    Failed to properly shut down NVML: Driver Not Loaded
    Reinstalling the drivers, Ubuntu, CUDA Toolkits also didn’t work.
1 Like