got error when trying to maximize the GPU speed.

I need maximize the performance without considering the power. According to the instruction http://elinux.org/Jetson/Performance . I have maximize the CPU freq. But I come across some issues when I am trying this command:

# echo 852000000 > /sys/kernel/debug/clock/override.gbus/rate
echo: write error: No such file or directory

I am sure I have root, sudo also doesn’t work. I tried to go to /sys/kernel/debug/clock/override.gbus/ and use Vim (with root) to modify rate file. but I still got error. I am sure the rate file is not missing…

"rate" E667: Fsync failed
WARNING: Original file may be lost or damaged
don't quit the editor until the file is successfully written!

same thing happened with file “state”, Did I miss something?
BTW. My tk1 version is 19.3
Thx a lot

You probably should upgrade the r21.1, although that shouldn’t affect your problem.

The errors look really odd, I can’t figure out, what could cause those.

Are you running the stock 19.3 kernel and environment (shell, etc.)?

ubuntu@tegra-ubuntu:~$ echo $SHELL
/bin/bash

If you run “sudo echo 852000000 > /something/something”, then the echo is run as root, but piping to the file is run as the normal user, so it won’t work.

Try this:

ubuntu@tegra-ubuntu:~$ sudo su -
root@tegra-ubuntu:~# cd /sys/kernel/debug/clock/override.gbus/
root@tegra-ubuntu:/sys/kernel/debug/clock/override.gbus# echo 852000000 > rate
root@tegra-ubuntu:/sys/kernel/debug/clock/override.gbus# cat rate
72000000
root@tegra-ubuntu:/sys/kernel/debug/clock/override.gbus# echo 1 > /sys/kernel/debug/clock/override.gbus/state
root@tegra-ubuntu:/sys/kernel/debug/clock/override.gbus# cat rate
852000000

wow!!!thank you very very much!!!
I borrowed another board and failed again. But your method really worked!! thanks a lot!!

This script works on both 19.3 and 21.1: https://gist.github.com/allanmac/c432b0fbfa4814f51d80

I am also having this issue, but for EMC everything works correctly.

I am running L4T 21.1, I have 2 boards that responds with the same error when trying to set the GPU clock. My performance is set on “userspace” with max performance in mind, might that be the problem?

PS: I get the following which does not make sense:

$ sudo cat /sys/kernel/debug/clock/override.gbus/rate
12000000
$ sudo cat /sys/kernel/debug/clock/gbus/possible_rates
72000 108000 180000 252000 324000 396000 468000 540000 612000 648000 684000 708000 756000 804000 852000

The rate listed in the first command is not listed in the ‘possible_rates’…

I have the same problem. This seems to be an issue with 21.4 because on 19.2 I didn’t have this problem.

Anyway, there’s a workaround: you have to run some function from CUDA before touching values in override.gbus. The following line does the trick (if you have python and CUDA):

python -c 'import ctypes; ctypes.cdll.LoadLibrary("/usr/local/cuda-6.5/lib/libcudart.so").cudaDeviceReset()'