GPIO error while trying to use PWM for LED dimming

Hello, I am a newbee here, trying to replicate the video experiment from Mr Paul McWhorter: https://www.youtube.com/watch?v=eImDQ0PVu2Y&list=PLGs0VKk2DiYxP-ElZ7-QXIERFFPkOuP4_&index=61

I had to run the troubleshooting instruction to set the Pin 33 to pwm2 as provided on: https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/hw_setup_jetson_io.html

The commands that I am using for getting started are:

import RPi.GPIO as gpio
gpio.setmode(gpio.BOARD)
gpio.setup(33,gpio.OUT)
my_pwm = gpio.PWM(33,500)
my_pwm.start(1)

But nothing happens. And so, when I exit out of the Python environment, below error log gets generated:
Exception ignored in: <bound method PWM.del of <Jetson.GPIO.gpio.PWM object at 0x7fa031e4e0>>
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/Jetson/GPIO/gpio.py”, line 606, in del
File “/usr/lib/python3/dist-packages/Jetson/GPIO/gpio.py”, line 622, in stop
File “/usr/lib/python3/dist-packages/Jetson/GPIO/gpio.py”, line 259, in _disable_pwm
NameError: name ‘open’ is not defined

Details about my board:
R32 (release), REVISION: 3.1, GCID: 18186506, BOARD: t210ref, EABI: aarch64, DATE: Tue Dec 10 06:58:34 UTC 2019
Jetpack version:
Package: nvidia-jetpack
Version: 4.3-b134

hello gunjan_narulkar,

please examine your PWM status as below,
i.e. $ sudo cat /sys/kernel/debug/pwm

please also refer to below forum discussion threads for reference,
thanks