GPIO not reflective of pinmux

Hello NVIDIA admin!

Currently working through a board bringup of a system.

I want to set the GPIO state of PIN 114: CAM0_PWDN as an output direction by default. Below are the steps and tests I went through:

  1. Edited pinmux:

  2. Used the python conversion tool to generate the .cfg

  3. Used skdmanager to deploy the new .cfg with the changes.

  4. Opened a terminal and got the GPIO ranges:
    $ cat gpio-ranges
    GPIO ranges handled:
    0: tegra-gpio GPIOS [288 - 495] PINS [0 - 207]
    208: tegra-gpio GPIOS [496 - 511] PINS [248 - 263]
    0: tegra-gpio-aon GPIOS [248 - 287] PINS [208 - 247]

  5. Added the gpio through export(288 +114pin = gpio402):
    echo 402 > export

  6. checked the direction of gpio402 by cat’ing direction and it returned “in”.

Is this normal behavior since I set the pin to an output state?

Hi seymoura,

Are you using the devkit or custom board for Xavier NX?

Have you tried to use flash script to flash your board with these changes?

Could you help to share the result of the following two commands on your board?

cat /sys/kernel/debug/gpio|grep PP.04 
sudo busybox devmem 0x02430070

Hi thanks for responding!

  1. I will be using a custom board for the Xavier.

  2. I have tried, its the same result.

  3. Results below:
    root@seymoura/$ cat /sys/kernel/debug/gpio|grep PP.04

    root@seymoura/$ busybox devmem 0x02430070
    devmem: applet not found

The first command returned nothing, not sure if that is what is supposed to happen.


Do you have the devkit to verify?

Are you using Xavier AGX or Xavier NX?

please use sudo for these 2 commands, both of them should return something.

Hi there,

I currently have the Xavier NX.

As for the commands below would root not provide the equivalent as sudo?
I did both of the commands and they both returned the same as my original message when run as sudo.

Not sure what to do here.


Do you have the devkit to verify with the same command?

Please also try to install devmem2 through apt.

$sudo apt-get install devmem2
$sudo devmem2 0x02430070

I cant install this on my current setup for some reason. I think its because I’m running a custom version of Yocto on the system.

Is there another test that can be run on my side that does not require a custom download of some kind?


Sorry, we don’t maintain or support Yocto project.
Please get L4T(Linux_for_Tegra) to verify GPIO function.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.