NX GPIO not working with Jetson NX Dev Kit

,

I writing a C++ program that will run on the NX using the Dev Kit board. I want to run headless and give the operator status information with LEDS driven by GPIO from the 40 pin header.

I have tried following the advice in the post How to config gpio07 as gpio and How to Enable GPIO7 and GPIO14 as PWM8 and PWM7 on Xavier-Nx module
with little luck.

The NX I am developing with shows no activity on the pins. I can export, set direction, and value through the command line without errors, but an oscope on the pins stays flat.

I tried a fresh install on a second NX and microSD, but I can only get pin32/gpio07 (424 as calculated and listed in a post) to toggle high and low NOT:
pin7/gpio09 (432 as calculated)
pin31/gpio11 (416 as calculated and listed in a post)
pin15/gpio12 (264 as calculated)

Is there something beyond the export, direction, and value writing that needs to be done to use the GPIO pins with the Dev kit?

hello nhschafer,

there’s default pin configurations.
you’ll need to access pinmux spreadsheets to have customization to generate cfg files, and re-flash the board to update the board.

you may also refer to https://github.com/NVIDIA/jetson-gpio, a Python library that enables the use of Jetson’s GPIOs.
thanks