Graph composer error while launching GLXBadFBConfig

Information about my laptop device:
OS and graphic card
Ubuntu 20.04.3 LTS/ Nvidia geforce 3080 for laptops

Hardware Platform (Jetson / GPU)


• DeepStream Version


• JetPack Version (valid for Jetson only)

• TensorRT Version

• NVIDIA GPU Driver Version (valid for GPU only)


• Issue Type( questions, new requirements, bugs)

I was trying to set up graph composer to test some of the new features. I followed the guidelines from the installing graph composer and I successfully installed the software.
The problem is that when I try to run the $composer in the terminal, the following output appears and the app doesn’t seem to launch:

I already tried the same operation but using the 470 from nvidia, and the 490 version aswell. In all these cases the output remained the same.

The following log was provided while running the command:
kit_20220114_114055.log (82.6 KB)

I’m a little bit lost here, I have already checked some other questions posted in the forums related to this issue but in my case the nvidia drivers seem to be working properly, and all the required packages for graph composer have been correctly installed.

Lastly I’m uploading a screenshot from nvidia-smi in my device, showing that the drivers are operative:

Any inputs regarding the issue are welcome, thank you for your time.

I suggest asking this question on a deepstream forum.

Thank you for your reply, since the forums would detect a duplicate question are you going to delete the current one?

Because I am guessing that I need to rewrite the question switching the category to deepstream, by the way there is no way of editing an already posted question to modify the category right? I need to create it again?

Do you need this topic opened or closed?

Hi, thank you for changing the tags to the required ones. I still need it open since I haven’t figured out how to solve the [GLXBadFBConfig] issue.
The only possible explanation to my knowledge may be updating the BIOS, I think I have read something regarding this aspect in some forums.
Any insights on this issue are very much appreciated.

Do you run the composer in docker container?

No, I run it locally