Gstreamer nvv4l2h264enc recorded video flicker issue

Hi,

I am capturing video using gstreamer with nvv4l2h264enc in recorded video i am having flickering isuue.

below is my pileline

gst-launch-1.0 -e -v v4l2src device="/dev/video0" do-timestamp=true ! “video/x-raw,format=BGRx,width=1680,height=1050” ! clockoverlay halignment=right valignment=bottom text=“Edge City” shaded-background=true font-desc=“Sans, 36” ! gdkpixbufoverlay location=spectross.png ! nvvidconv ! “video/x-raw(memory:NVMM),width=1680,height=1050,format=I420,framerate=60/1” ! nvv4l2h264enc maxperf-enable=1 insert-sps-pps=1 insert-vui=1 profile=4 preset-level=4 control-rate=1 bitrate=8400000 ! h264parse ! rtph264pay ! shmsink socket-path=/tmp/test3 shm-size=20000000 wait-for-connection=false pulsesrc device=alsa_input.usb-BurrBrown_from_Texas_Instruments_USB_AUDIO_CODEC-00.analog-stereo ! queue ! audioconvert ! lamemp3enc ! rtpmpapay ! shmsink socket-path=/tmp/audio3 wait-for-connection=false shm-size=1000000

gst-launch-1.0 -v -e shmsrc socket-path=/tmp/test3 do-timestamp=true is-live=true ! application/x-rtp,clock-rate=90000 ! tee name=t ! queue ! rtph264depay ! video/x-h264,stream-format=avc,alignment=au ! h264parse ! matroskamux name=mux ! filesink location=video1.mkv sync=true shmsrc socket-path=/tmp/audio3 do-timestamp=true is-live=true ! application/x-rtp,media=audio,clock-rate=90000,encoding-name=MPA ! tee name=aud ! queue ! rtpmpadepay ! mpegaudioparse ! mux.

i am attaching recorded video also please have look and tell me what setting i should chane for encoder or anything else

Regards
Parth

Hi,
The issue may be from audio/video synchronization. Please try video-only case. Check if it happens in video-only pipelines.

Hi, DaneLLL

I have recorded only video as per your suggestion but isuue is still there. so can you suggest any other possible sollution.

Hi,
Please check if it happens in saving to local file.

gst-launch-1.0 -e -v v4l2src device=/dev/video0 do-timestamp=true ! 'video/x-raw,format=BGRx,width=1680,height=1050' ! clockoverlay halignment=right valignment=bottom text="Edge City" shaded-background=true font-desc="Sans, 36" ! gdkpixbufoverlay location=spectross.png ! nvvidconv ! 'video/x-raw(memory:NVMM),width=1680,height=1050,format=I420,framerate=60/1' ! nvv4l2h264enc maxperf-enable=1 insert-sps-pps=1 insert-vui=1 profile=4 preset-level=4 control-rate=1 bitrate=8400000 ! h264parse ! matroskamux ! filesink location=a.mkv
gst-launch-1.0 -e -v v4l2src device=/dev/video0 do-timestamp=true ! 'video/x-raw,format=BGRx,width=1680,height=1050' ! nvvidconv ! 'video/x-raw(memory:NVMM),width=1680,height=1050,format=I420,framerate=60/1' ! nvv4l2h264enc maxperf-enable=1 insert-sps-pps=1 insert-vui=1 profile=4 preset-level=4 control-rate=1 bitrate=8400000 ! h264parse ! matroskamux ! filesink location=a.mkv

or video preview:

gst-launch-1.0 -e -v v4l2src device=/dev/video0 do-timestamp=true ! 'video/x-raw,format=BGRx,width=1680,height=1050' ! nvvidconv ! 'video/x-raw(memory:NVMM),width=1680,height=1050,format=I420,framerate=60/1' ! nvoverlaysink

HI DaneLLL,

This isuue is because of source i am taking i have check it on preview.
and it only came if i am taking input from widows as my input is VGA. in ubantu there is no issue.

Regards
Parth.