GstV4l2Src:v4l2src0: Internal data flow error after RUN gst-launch-1.0.

I use jetson tx1 R28.2 ,and imx219 sensor.

I run the command as below:

gst-launch-1.0 -v v4l2src device=/dev/video0 num-buffers=1 ! "video/x-bayer, format=rggb, width=3280, height=2464" ! filesink location=test_3280x2464.bayer

but there are some error:

Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Internal data flow error.
Additional debug info:
gstbasesrc.c(2948): gst_base_src_loop (): /GstPipeline:pipeline0/GstV4l2Src:v4l2src0:
streaming task paused, reason not-negotiated (-4)
Execution ended after 0:00:00.000241251
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...
nvidia@tegra-ubuntu:~$

How can fix this question?

hello sensor_test,

please check the kernel message, let’s use same discussion thread if this show same kernel failure as topic 1032232.
thanks

hello sensor_test,

seems you had fix the “Internal data flow error.” failure.
you found a new issue that RAW data is alway ZERO here: https://devtalk.nvidia.com/default/topic/1032388/

i would suggest you sharing the fixes or information,
and please accept the answers to let other developer to understand this discussion thread already have a solution,
thanks

NO.
this question is still exist.
Can you tell me HOW can fix this?

hello sensor_test,

please read my comment #2,
thanks

hello sir
i am also getting the same error how can i fix it .please give the solved link to ref
i hope this very helpful for me

hello sriramar1999,

this is already a two years old topic, may I know are you still working with l4t-r28.2 release.