GTX 1650 No CUDA support


Before and after installing the Cuda toolkit, all the programs showed that I did not have CUDA support. But at the same time, when installing the CUDA Toolkit, the video card did not cause errors when checking compatibility. I want to use thensorflow and pytorch with CUDA, but I can’t do it, everything says that CUDA is not supported, but on wikipedia and this forum it was said that there is support. Has anyone ever encountered this? Any ideas? I often reinstalled drivers and used different versions of the CUDA Toolkit. Tensorflow output: >>> tf.test.is_gpu_available() 2021-04-22 22:29:08.566843: I tensorflow/core/platform/cpu_feature_guard.cc:142] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2 2021-04-22 22:29:08.572678: I tensorflow/stream_executor/platform/default/dso_loader.cc:44] Successfully opened dynamic library nvcuda.dll 2021-04-22 22:29:08.613909: E tensorflow/stream_executor/cuda/cuda_driver.cc:318] failed call to cuInit: CUDA_ERROR_NO_DEVICE: no CUDA-capable device is detected 2021-04-22 22:29:08.617089: I tensorflow/stream_executor/cuda/cuda_diagnostics.cc:169] retrieving CUDA diagnostic information for host: DESKTOP-7CR4M12 2021-04-22 22:29:08.617240: I tensorflow/stream_executor/cuda/cuda_diagnostics.cc:176] hostname: DESKTOP-7CR4M12 False

2 Likes

Did you ever find an answer to this issue?

No, but reinstalling Windows helped. I guess the reason was in some disabled services that were manually disabled a long time ago.

I have the same issues with GTX1650 Super. I tried installing the drivers in the windows side and it seems to work fine and I was able to use tensorflow-gpu withouit any problem yet. The problem arises when I tried to run the tensorflow in WSL2. It always shows that I do not have an appropriate cuda-enabled gpu: lspci shows nothing and running cuda apps results in error 35: insufficient drivers.

I followed the installation in https://docs.nvidia.com/cuda/wsl-user-guide/index.html

Now I have to find a way to integrate bash commands into windows, waiting for the officials to list the GPUs into their list. I hope they will do it very soon.