HardDPMS option for nvidia-xconfig

Currently nvidia-xconfig does not support the HardDPMS option.
Since the default value was changed since the 440.x driver it might be a good idea to add this to allow for an easy change.

This is required for VirtualGL to work properly for example, see: https://virtualgl.org/Documentation/HeadlessNV

Currently we modify the xorg.conf to add this, but an option for nvidia-xconfig would be preferred to accomplish this.

I hope someone can forward this request to the devs :)
Initially created a ticket but was told to post in the Forums instead.

The HardDPMS option was supposed to be temporary, so I’d be interested to know whether it’s actually still needed in the most recent drivers.

As far as I understand, the original problem with HardDPMS and VirtualGL was that the frame rate limiter still kicked in when DPMS was activated even if there were no displays active. That was fixed in newer drivers, so they should no longer apply the frame rate limit on headless systems.

Can you please try 455.28 to see if this option is still needed?

We are currently using the 450.51.06 release.
I can run some tests with the latest release, was there a change regarding that since then?
Do you have some information when this option is supposed to be removed?

The frame rate limiter started to kick in when HardDPMS was enabled after the Virtual Desktop was idle for some time and the user reconnected.
When connecting for the first time the performance was actually fine, so it looks like it didn’t get out of these low power states properly again.

Looks like the first release with this change was 440.59:

450.51.06 should have that behavior change too.

It’s possible that some applications throttle themselves when DPMS is active regardless of what the driver is doing. You may want to consider disabling DPMS entirely with xset s off -dpms or by disabling the DPMS option in xorg.conf.

The option is more then neccessary I am afraid.
Without “HardDPMS” “true” my DP connected display will not ever shut off.
With Windows it “just works”, with Linux it does after setting the option.