Headless x11vnc + nvidai driver version 3.xx + rhel6.4 (centos 6.4) desktop background and panels li

We are using x11vnc to remotely work on headless machines using their nvidia GPUs for 3D.
The VNC desktop (turbovnc or tightvnc) comes up with the expected resolution we’ve set in xorg.conf (3820x1050) but the desktop background and panels are limited to a field of 800x600(?) pixels, I can move windows beyond this field using the whole 3820x1050 area.
This issue arose with Centos 6 running 3.xx nvidia drivers and seems to apply to several GPU models.
We had no issues running 3.xx drivers under Centos 5.
As a workaround we installed the latest 2.xx driver, but since Centos 6.4 we seem to be limited to nvidia driver version 3.xx
We would like to run the latest driver, but would temporarily accept a solution to run 2.xx drivers on Centos 6.4

Thanks
nvidia-installer.log (41.8 KB)
nvidia-bug-report.log.gz (77.9 KB)

This is probably because without an EDID, nvidia-auto-select is being set to the conservative default of 800x600 with a 3820x1050 panning domain. The actual mode gets reported via RandR 1.2 and via the Xinerama extension.

Do you actually need the fake DFP device you’re setting with the ConnectedMonitor option? You might have better luck if you use

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Headless"
    Option         "UseDisplayDevice" "none"
    SubSection     "Display"
        Virtual 3820 1050
    EndSubSection
EndSection

As an alternative, you can create a custom 3820x1050 mode for the fake DFP device, but you’ll have to jump through some additional hoops to convince the driver that that mode is valid.

Xorg doesn’t start with these settings.
Xorg.0.log (8.35 KB)
xorg.conf.txt (763 Bytes)

It looks like this happened because this version of the driver requires that virtual sizes have widths that are a multiple of 8.

[1365314.817] (WW) NVIDIA(0): NoScanout X screen width adjusted from 3820 to 3824 (width
[1365314.817] (WW) NVIDIA(0):     must be multiple of 8)

Does it work if you remove the MetaModes option or adjust its width to 3824? Alternatively, this restriction is relaxed in 319.12 so you should be able to use 3820.

Tried 3820 with 319.12 and 3824 with 310.44, both work!

Thank you heaps!