Has anyone been able to run an RTX 3060 laptop GPU at more than 80W on Linux?

Yeah, good feature if it’s working out-of-box. I don’t understand why some basic GPU TGP settings are not implemented in BIOS, it could be done very simple by one entry with at least 3 options like:

  1. Automatic TGP (API, Driver, etc.)
  2. Manual - Low TGP (Base: 80W, Boost: OFF)
  3. Manual - High TGP (Base: 115W, Boost: ON)

And no one will complain…

Can confirm that this is the case with the RTX3050 in my Lenovo Legion 5i Pro 16 - 82JF002RUS

The GPU is running at 40w instead of the listed Lenovo spec of 95w.

Looks like this is a major issue since all mobile Ampere/Turing refresh chips seem to have a configurable TGP now, while nvidia locked setting PL using nvidia-smi on mobile gpus.
Since the limits are set in VBIOS, I guess ACPI doesn’t help with that, the linux driver is simply missing the feature to acknowledge it.
Did anyone test if nvidia-smi -pl works in Windows?

Please share the outputs of
cat /proc/driver/nvidia/gpus/0000:01:00.0/information
cat /proc/driver/nvidia/gpus/0000:01:00.0/power
Thanks.

@generix yes you’re right it’s most likely a missing feature in Linux drivers with software caps coded in. But I do believe there are some ACPI interactions involved.

@fallenfaux that’s rough.

This mess resembles the previous driver shortcoming/failure on mobile gpus when nvidia introduced the settings
GPU Max Operating Temp
GPU Target Temperature
Always locking the gpu to the vendor preset target temp, which was often very low thus the gpus throttling and at the same time preventing to set the target using nvidia-smi, breaking notebooks that were fine with a previous driver. Don’t know if this has ever been fixed.
I guess this both is just a case of nvidia restricting the usage of nvidia-smi on mobile gpus too much for the new configurable target power and temperature.
So I repeat my request to check if nvidia-smi -pl works in Windows.

I tried nvidia-smi -pl on Windows, doesn’t work. Same as Linux (“hardware doesn’t support…”) @generix

I’d imagine whatever interface nvidia-smi uses is obsolete for Ampere. Or Ampere mobile, at least.

Did not know about the temp settings issue but I really hope this issue is addressed at least. How exactly does one report an issue? Or get a response from Nvidia devs? This really isn’t a minor problem. Is there someone we can tag here and alert them of the issue?

The devs are reading the forum, so this silence is loud. You can also post a bug report here:
https://developer.nvidia.com/nvidia_bug/add
YMMV
Since with Tuxedo actually a vendor acknowledged the issue and contacted nvidia, hopefully this will have some greater impact.

1 Like

Thank you generix.

I have same problem with RTX 5000 laptop GPU stuck at 80w. In windows it goes to 100w. Also problem is same with 495 and latest vylkan beta driver. With previous drivers from 470 series GPU will go to 90w.

Yup thanks @generix, big help in the absence of a response from Nvidia.

@phusho interesting case. I believe this the exact same issue and your case just confirms that this is indeed an nvidia driver issue.

Any update on the situation yet? @phusho ahh thats because dynamic boost is not supported on the linux platform yet.

No update that I know of.

Also @phusho’s issue is probably not related to dynamic boost because it does 90W on 470 but 80W on 495. It’s some other driver issue.

Decided to get something with an RX 6800M instead.

Its much better than nvidia under linux good choice.

the same problem here, legion 5 (ryzen 5 4600, rtx2060) on win 10 115w, on arch 80w. its really disappointing

Has anyone tried what the Arch Wiki says?

https://wiki.archlinux.org/title/NVIDIA/Tips_and_tricks#Kernel_module_parameters

On some notebooks, to enable any nvidia settings tweaking you must include this option, otherwise it responds with “Setting applications clocks is not supported” etc.

/etc/modprobe.d/nvidia.conf

options nvidia NVreg_RegistryDwords="OverrideMaxPerf=0x1"

No it didnt do any changes. I still wonder how this isnt fixed for that a long time if even 2000 series GPUs have the same problem.

@gardotd426 tried it, doesn’t work for setting power limits. It’s probably for adjusting clock speeds.