Has anyone been able to run an RTX 3060 laptop GPU at more than 80W on Linux?

Now the tension rises, the new 510 beta contains the mysterious nvidia-powerd+systemd file again, which shortly appeared in 460 and then vanished.
Looking at the strings, it seems it reads the cpu power budget and then calculates and sets the gpu power limit.
No batteries, err, manual included.

1 Like

Where we can get that driver?

Ah i tried them its still 80 Watts fixed. Nvidia always late with linux fixes.

What kind of messages are printed if you run it (as root)?

NB: I don’t think this is auto-installed, you’ll have to unpack the runfile with option -x and then manually grab nvidia-powerd
I guess this is meant for vendor-side testing currently but shouldn’t keep users from experimenting.

Ah i found the culprit so zen3 cpu consumption cannot be computed yet, its still isnt available in the kernel so nvidia-powerd.service cant be started need to wait more i guess.

Refuses to run with these output

Jan 13 13:21:10 tux systemd[1]: Starting nvidia-powerd service…
Jan 13 13:21:10 tux /opt/bin/nvidia-powerd[25182]: nvidia-powerd version:1.0(build 1)
Jan 13 13:21:10 tux /opt/bin/nvidia-powerd[25182]: Error in loading msr module
Jan 13 13:21:10 tux /opt/bin/nvidia-powerd[25182]: Failed to read the data for calculating CPU power
Jan 13 13:21:10 tux /opt/bin/nvidia-powerd[25182]: Failed to initialize GPU Boost controller

I wonder if it’s trying to read raw data from msrs or rather digested data from intel_rapl which should have zen123 support as of kernel 5.11.

nvidia-settings 510 now includes setting
Quiet/Balanced/Performance modes
https://github.com/NVIDIA/nvidia-settings/blob/main/src/gtk%2B-2.x/ctkpowermode.c
obviously limited to (selected?) intel cpus for now.

Ah sad!

This is great progress. The driver seems to be heading in the direction of supporting different power modes.

I haven’t installed this driver yet so unable to comment. Has anyone tried it on 5.17? Perhaps there is support in it for zen3 power consumption.

Will share an update here if I’m able to test it. Thanks @generix & others!

Still buggy though, even if it runs:
https://forums.developer.nvidia.com/t/510-39-01-beta-driver-nvidia-powerd-causing-high-system-load/200839

Yeah I tried it with 5.17-rc1 but sadly still power consumption of the zen3 cpu cannot be calculated. Powerd gives the same errors.