Has someone tried to capture more than 80fps 1080p?


We are trying to capture MIPI CSI-2 4 lanes at +80fps with 1080p. We can get 80fps but if we go beyond 80fps the frames per second start jumping to 120, 80, 90, randomly. Has NVIDIA or someone else tried capturing +80fps? We are using V4L2.


Trying to determine if this is a problem or limitation on the tegra X1 I started looking on the technical reference manual. Page 2391 mentions the expected performance of the CSI 2 input.

Table 155 says that there are 4 speeds for the MIPI CSI (600Mbps, 800Mbps, 1Gbps, 1.5Gbps) and according to it this Table shows the maximum amount of Mp/s. In our case we are using:

1.5 (4 lanes)/(Raw 8) = 750Mp/s

If that is the case and using also Table 156 as reference then the maximum framerate should be:

(750 000 000) / (1920x1080)=362.7fps

Now, the TRM mentions that 15% should be reduced due protocol and blanking, this would then produce 307.4 fps. So we should not have framerate problems. Now my questions are:

a) The numbers above are for the physical interface, would this apply for the VI too? Or does VI has a limit that could be reducing this amount of fps?

b) I am assuming that we are using a link speed of 1.5 Gbps, but Table 155 shows that MIPI CSI could be in 600Mbps, 800Mbps, 1Gpbs as well. Is there some way to know the speed that Tegra X1 is using?

Thanks in advance,

I was just did a test and was able to encode 1920x1080@120fps using our own camera module with gstreamer and nvcamerasrc. The resulting file played back correctly on a Mac using VLC, with resolution and frame rate reported as expected. CPU Usage was generally around 25-40% with a couple spikes. This is a Sony IMX274 sensor on CSI port 1.

gst-launch-1.0 -e nvcamerasrc fpsRange="30.0 120.0" ! 'video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, format=(string)I420, framerate=(fraction)120/1' ! omxh265enc ! 'video/x-h265, stream-format=(string)byte-stream' ! h265parse ! matroskamux ! filesink location=test.mkv -e

Hi Sperok,

Interesting, we are using v4l2 instead of nvcamerasrc. Did you modify the code to support the IMX274? Did you have to set the link speed in some place of the code?


I think the problem is related to soc camera.

Hi Sperok,

I have been recently experimenting with Leopard Imaging’s IMX185 kit. There is a .dtb file for the camera provided with recent versions of L4T, however the only supported mode is 1080p30. Could you give me any guidance as to where should I start in order to configure the camera for other modes? I would be very grateful for even a bit of help, as I usually work on higher level software and this issue is kind of new to me.


@westej - My earlier comment was based on code supplied directly by Leopard Imaging with no modification on my part. Since upgrading to Jetpack 2.3.1 I have not verified this, but suspect that the 120fps modes have been removed.