Hash Sum Mismatch - Ubuntu 14.04


My automated build system for gorgonia is reporting an error:

E: Failed to fetch http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1404/x86_64/./cuda-visual-tools-8-0_8.0.61-1_amd64.deb  Hash Sum mismatch

This is the TRAVIS-CI file to install:

travis_retry sudo add-apt-repository -y ppa:graphics-drivers/ppa
travis_retry sudo apt-get update -qq
travis_retry sudo apt-get install -f -y nvidia-378 nvidia-378-dev libcuda1-378 nvidia-settings nvidia-opencl-icd-378
travis_retry sudo apt-get install -f

travis_retry wget http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1404/x86_64/cuda-repo-ubuntu1404_${CUDA}_amd64.deb
travis_retry sudo dpkg -i cuda-repo-ubuntu1404_${CUDA}_amd64.deb
travis_retry sudo apt-get update -qq

export CUDA_APT=${CUDA:0:3}
export CUDA_APT=${CUDA_APT/./-}
travis_retry sudo apt-get install -f -y cuda-drivers cuda-core-${CUDA_APT} cuda-cudart-dev-${CUDA_APT} cuda-cufft-dev-${CUDA_APT}
travis_retry sudo apt-get install cuda
travis_retry sudo apt-get clean

The CUDA environment variable is static at



The builds previously passed. Anyone knows what’s happening?

I’m running into the same issue executing the following in a clean docker-container:

wget http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1404/x86_64/cuda-repo-ubuntu1404_8.0.61-1_amd64.deb
sudo dpkg -i cuda-repo-ubuntu1404_8.0.61-1_amd64.deb
sudo apt-get update
sudo apt-get install cuda

This fails with:

E: Failed to fetch http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1404/x86_64/./cuda-visual-tools-8-0_8.0.61-1_amd64.deb  Hash Sum mismatch

Seems related to this issue - it’s the same program: CUDA Visual Tools 8.

Anyone from nvidia here?

Same problem here!!

I was trying to install using cuda-repo-ubuntu1404-7-5-local_7.5-18_amd64.deb

I’ve just raised this with nvidia support via live chat:

Subhanshu: Hi, my name is Subhanshu. How may I help you?
Me: as per my message
Me: I’m not able to install cuda-visual-tools-8-0 from your ubuntu repo
Me: currently the hash sum recorded by the repo doesn’t match that of the file that is downloaded
Me: can you advise how I can get someone to fix this?
Subhanshu: I apologize for any inconvenience this may have caused. Please be assured that I will do my best to help you further or point you in the right direction.
Me: thanks
Subhanshu: Please visit the given link http://docs.nvidia.com/cuda/cuda-installation-guide-linux/#axzz4fGDP1BCR
Me: thanks but this is not an issue with my config, there is something wrong in the repo, please check other people reporting the same issue in your forum:

Me: … hello?
Subhanshu: Please update me with the following details to check this further.

  1. GPU Model
  2. OS details
    Me: OS = Ubuntu 14.04.5 LTS
    Me: GPU = 04:00.0 VGA compatible controller: NVIDIA Corporation GK110 [GeForce GTX 780] (rev a1)
    Subhanshu: Thank you for the details, I request you to give me sometime to get this checked. I’ll keep you posted via email as soon as I get an update.
    Me: ok, can you give me an estimate of how long this could take?
    Subhanshu: Getting an update may take a day or two?
    Subhanshu: We’ll keep you posted as soon as there is an update.
    Subhanshu: Please let me know if there is anything else apart from this I may assist you with.

TIL there is a live chat. And it’s not particularly useful

@Rumbles can you update this thread when you get the email?


Thanks for raising this. Looks like this file was corrupted using our upload process. The bad file has been replaced.

Please do try again and let me know if you have any problems.


Thanks, I can confirm that this appears to have fixed the issue I was seeing

The problem was solved.
Thank you.

Agreed. Problem was solved.


Same here, many thanks!

Is this related to the cuda-visual-tools-8-0.x86_64 corrupted on yum repo issue?

That seems to not have been solved yet.