HDMI display resolution on Jetson Xaiver NX (8GB) is freezed

I have Jetson Xaiver NX (8GB) development kit. Recently I flashed L4T 35.3.1 on NVMe using SDKManager. No SD card present on development kit.

HDMI display resolution is freezed to 1280x720.

Is it QSPI hardware failure because I see edid read error
6.331193] tegradc 15200000.display: hdmi: edid read failed
from attached log.

dmesg (74.6 KB)

Is the monitor purely HDMI (or DisplayPort)? Or is there an adapter?

Is the Jetson a developer’s kit from NVIDIA, or is it using a third party carrier board?

Monitor purely HDMI no adapter.

Jetson development kit is from NVIIDA not from third party.

It is indeed an EDID failure, but let’s test further. Can you boot without the monitor, but use the serial console to monitor boot logs? If so, once serial console reaches where you can log in, do so, and monitor “dmesg --follow”. Then, and only then, plug in the monitor. What log lines occur as a result of the plugin?

Also, if booting with the monitor already connected (a separate boot), include both the full serial console boot log like before, but also add the “/var/log/Xorg.0.log” which occurs with that particular serial console boot log.

Incidentally, have you tried other HDMI monitors?

Hi linuxdev,

Thanks for your debugging steps.

I connected micro USB port of Xavier NX to Windows laptop and used PuTTy in serial mode. When I power up Xavier NX board after few seconds it is detected in Windows as COM port and then in PuTTy I get login screen. I logged in and ran “dmesg --follow” but I get message “dmesg: read kernel buffer failed: Operation not permitted”. I connected HDMI monitor to Xavier NX board and I can see ubuntu desktop which shows HDMI resolution 1280x720 and which I can’t change it.

Please check attached “Xorg.0.log” collected from ubuntu.

I hope I followed your steps correctly.

I am using same HDMI monitor on windows laptop and it is showing correct display resolution.
Xorg.0.log (21.9 KB)


It may not be “QSPI hardware failure” because if QSPI is corrupted, you won’t even see the system up.

Please try to flash your system to emmc first and see if you can still see the same monitor has same problem.

If there is, please switch to other monitor to test.

Please be aware that this is just debug process.

I don’t know the meaning, but it also looks like the Xorg.0.log was “odd”. It definitely did not detect HDMI, which is why it switched to a default mode of 1280x1024, and then 1280x720 (does your monitor support that?).

Also, this is very odd and seems serious:

“dmesg: read kernel buffer failed: Operation not permitted”

It’s like the kernel is modified and set up wrong.

Also, if you were able to use PuTTY, then PuTTY should have the ability to log an entire session. In that case you could start logging prior to powering up the Jetson, and provide the boot log itself. dmesg is not needed if you get a serial console boot log.

Hi Linuxdev,

I am unable to take log in PuTTy from Xavier NX power ON.

My same monitor works with Windows laptop and other Ubuntu desktop with 1920x1080 resolution.

I see NVIDA logo at boot screen at 1920x1080 resolution but later it is reduce to 1280x720 on Xavier NX.

Hi WayneWWW,

I am trying to reflash QSPI again. I see QSPI flashing process but I get error
sudo flash_eraseall /dev/mtd0
flash_eraseall has been replaced by flash_erase <mtddev> 0 0; please use it
flash_erase: error!: can’t initialize libmtd

I am referring QSPI flash process from page

Which is

which points to

Please check this webpage address. It says it is pointing to “r35.1” but page actually shows content for 34.1

Please share correct page link for JetPack 5.1.1 which shows
flash_erase <mtddev> 0 0 command process.

Also how many blocks are present on Nvidia jetson xavier NX 8GB module QSPI chip?

I also tried but also get error.
sudo flash_erase /dev/mtd0 0 255
flash_erase: error!: can’t initialize libmtd

That method won’t work. Just reflash the whole board with sdkmanager.

Only sdkmanager can flash the QSPI now. That method on device side won’t work anymore.

Explaining the reason of why flashing QSPI from device won’t work is out of the direction of this issue. So please don’t put too much effort on that. Just reflash the whole board first.

Hi WayneWWW,

I flashed again xavier NX again using SDKmanager but no change in HDMI resolution setting issue.

So, I tried to rollback JetPack to 4.6.2 and it failed. Please check attached log.
log_1 (25.2 KB)

I followed process from section " Downgrade to JetPack 4.X"


I flashed again xavier NX again using SDKmanager but no change in HDMI resolution setting issue.

please share the dmesg on that version first.

Also, please do any flash work with sdkmanager only. Do not flash by the board by with any random commands by yourself.
Sorry to say that but I think you are not familiar with all of these so your random try just causes pointless log.


I get error for dmesg command:
“dmesg: read kernel buffer failed: Operation not permitted”

I used commands from Nvidia user guide not any random commands

Are you able to log in by any method? If so, what do you see for “uname -r”? Does “sudo ls” work?

If not able to log in, did you use a modified kernel? If not able to log in, what was the source of the rootfs content? Mainly, for this latter question, I’m wondering if what got flashed is a filesystem type ext4, or if it has the wrong filesystem type (which modifies security and prevents sudo from working).

We have lots of kind of flash method and parameters in use there.

If you don’t know the meaning of some specific parameters, then please follow my instructions first.

Also, if you saw dmesg give this, then just run it with “sudo dmesg” as @linuxdev said here.

“dmesg: read kernel buffer failed: Operation not permitted”

Also, please help clarify what is the exact BSP version you want to use. For example, must run dmesg with sudo is something from rel-35(jp5)… but it looks like you are referring to a rel-32 (jp4) document.


Please see attached logs.
SDKmanager_flash.log (36.2 KB)
dmesg_log (79.6 KB)
Xorg.0.log (23.0 KB)

This is what I flashed through SDKmanager:
NVIDIA NVIDIA Jetson Xavier NX Developer Kit
L4T 35.3.1
Ubuntu 20.04.5 LTS
Kernel Version: 5.10.104-tegra
CUDA Architecture: 7.2
OpenCV version: 4.2.0
OpenCV Cuda: NO
Vulcan: 1.3.204

I hope these logs will help you to analysis.


Please try other native HDMI monitor and HDMI cable and see if there is also

[ 6.481662] tegradc 15200000.display: hdmi: edid read failed
[ 6.481904] tegradc 15200000.display: hdmi: using fallback edid
[ 6.482128] tegradc 15200000.display: blank - powerdown

If there is, then try other XNX modules or carrier board to cross check.

This is more like a hardware problem but not software.


Thanks for confirming.

My windows and ubuntu laptops works fine with same HDMI cable and same monitor. I don’t have other Xavier NX.

As I purchased this development board in year 2020 now it is out of warranty. So no scope for RMA.

There is any way you can provide me QSPI chip part number by checking into Xavier NX module schematic? I will try to get it replaced from professional electronics repair shop.


I am really confused by your persistence on QSPI. Why do you keep thinking your issue is related to QSPI?

Your issue is on kernel and kernel is on the emmc but not QSPI. Why do you think replacing “QSPI” can fix things here?


Correct me if I wrong.

Xavier NX module comes with SD card or eMMC.

And my Xavier NX 8GB is a development kit and which has SD card slot.