Jetson TX1 not booting up

Hello Everyone

Please could you help me I’m having a problem with Jetson TX1 there is no display in screen while booting up. I’m using LG 20M38H monitor HDMI LED monitor.

Do i need to adjust the resolution.

Thanks in Advance

AMITAVA

Do you have serial console or ssh to work through? If so, paste the content of:

sudo cat /sys/kernel/debug/tegradc.1/edid

The EDID data will show if Jetson was able to query the monitor automatically for its capabilities. Sometimes a query fails due to simple things like cable adapters, but at other times there have been issues with default resolution when native resolutions failed.

Meanwhile, try booting the Jetson with no video cable connected; then, after about a minute, connect the monitor cable and see if this changes things (video signal in text mode during boot differs from video mode in graphical mode…HDMI is hotplug and starting with the graphical mode signal might give different results than first using console mode in cases where EDID fails).

Hello

Thanks for the reply. I’ll try. Meanwhile I want to know is there any resolution setting to be done in monitor

Thanks in Advance
AMITAVA

In the early days the 15-pin VGA cable had no means for the computer to query details of the monitor. Newer cables support EDID to query those values.

If you do not have EDID, then you manually set things like resolution (perhaps like the old driver disk or a list of modes from a monitor database). With EDID the manual stuff was mostly removed…you can edit “/etc/X11/xorg.conf” and fill in values exactly as the old days did. If EDID fails then you must do this. Should EDID fail there will be a default fallback mode from among a set of some standard modes…should your monitor support that mode, then it will “just work”.

Whatever the current fallback mode is it seems your monitor does not support it. To do any manual tweaking you will need exact monitor specifications so you can create modelines. It’s easier to first see if EDID can be debugged. About modelines:
https://en.wikipedia.org/wiki/XFree86_Modeline

Thanks for the info. Again I want to know I’m having a PuTTY release 0.67 installed in Win 7 based 64 Bit Laptop. Can i use it as serial console.

Regards
AMITAVA

PuTTY works as serial console. I don’t remember what setup details were, but I have used it before as serial console (it’s kind of rare that I use a Windows box while developing software). Just make sure it is set to 115200 8N1 (and if you have CTS/RTS use that for flow control…if not use software flow control).

Hello

Thanks for your reply. I checked with
sudo cat /sys/kernel/debug/tegradc.1/edid

it replied NO EDID

please could you guide me next steps

Thanks in Advance
AMITAVA

HDMI should have EDID, so this makes me wonder about cabling. If the cable is purely HDMI with no intervening adapters, then something is wrong (probably in the cabling). Can you describe if any adapters are used with the cable between monitor and Jetson? If there are no adapters, do you have a different HDMI cable you can try? Can you also look closely at each end of the cable and look for bent or broken pins?

Hello…

Presently I’m using HDMI 2.0 cable by MX however I’ve ordered another pair of HDMI 2.0a from Kenable which is expected to arrive soon. There is no intermediate connector.

I’ve checked the monitor works fine once I connect with my laptop. Does it means Monitor is not supporting the Jetson TX1. In such case is there any remedy without replacing the monitor.

Thanks in Advance
AMITAVA

The EDID response is available on all natively HDMI monitors or televisions. Without that EDID it isn’t a case of whether Jetson or the monitor support each other…it’s a unified standard of configuration and is likely related to the cable (if the cable is good then there would be a hardware failure involved at either monitor or computer end). Even though the monitor and computer will work together if the default configuration happens to be good for both, it is something of blind luck (or lack of luck) that determines if monitor and computer default to a matching mode when auto-configuration is missing.

I suggest waiting until the new cable and seeing what happens…do check for bent pins and fully seated connectors on the current cable.

Hello…

Thanks for the information. I tried at another location using DELL monitor found booting screen but my LG20MH28 do not works. is it LG monitor do not support Jetson TX1, i need an alternate solution because I’m not in a position to replace the monitor.

Thanks in advance.

Regards
AMITAVA

I have found that some cables work on some monitors but not others. Not having EDID is the symptom, but the cause could be cable (likely) or monitor (with HDMI this is unlikely). To verify EDID works on the Jetson end, take the DELL and see if you now have data in:

sudo cat /sys/kernel/debug/tegradc.1/edid

If the DELL has data on the Jetson, then you’ve validated that the EDID query is functional at the Jetson end (it doesn’t claim use of EDID is correct, just that the wire/cable and electrical part works…this is all you need to verify at the moment).

On another Linux computer you could do some things to see if EDID works with the LG. Most Liux distributions won’t provide EDID raw data in “/sys”, but you can run “xrandr” and if monitor specs can be found, then you know your monitor is providing EDID on that other computer…this would be close to “a smoking gun” evidence that it is a cable issue. Should xrandr fail on the other computer which the monitor works with, then I’d say you just got lucky with the other computer using a default mode the LG works with. Can you verify xrandr works with the LG on another computer?

It is rather uncommon for an HDMI device to not respond to EDID (this is part of the HDMI standard), and if changing the cable can fix this, then that is the best route (I’ve seen several HDMI cables which were technically working, but of low enough quality that only some monitors worked with the cable).

If there is no EDID, then you will have to manually set up modelines…this is not trivial (you would essentially have to research the monitor and then set everything up manually based on those specs the same as EDID software would have done).

Hello…

I got a new HDMI 2.0 cable when I plugged Jetson TX1 with my HDMI monitor it doesn’t shows up any thing
in display. I Connected serial console and found the following It seems after 3.28 sec the system had
stopped booting.

[ 3.184015] display board info: id 0x0, fab 0x0
[ 3.189075] display board info: id 0x0, fab 0x0
[ 3.193357] invalid panel compatible
[ 3.196384] parse_tmds_config: No tmds-config node
[ 3.201325] of_dc_parse_platform_data: could not find vrr-settings node
[ 3.207731] of_dc_parse_platform_data: nvidia,hdmi-vrr-caps not present
[ 3.214462] of_dc_parse_platform_data: could not find SD settings node
[ 3.220818] of_dc_parse_platform_data: could not find cmu node
[ 3.226641] of_dc_parse_platform_data: could not find cmu node for adobeRGB
[ 3.233609] tegradc tegradc.1: DT parsed successfully
[ 3.239818] display board info: id 0x0, fab 0x0
[ 3.243886] gpio wake53 for gpio=225
[ 3.273304] V_REF_TO_SYNC >= 1; H_REF_TO_SYNC < 0
[ 3.276030] tegradc tegradc.1: Display timing doesn’t meet restrictions.
[ 3.283786] tegradc tegradc.1: probed

When i connect with my LG 20M38H monitior after approximate 2 Minutes I re runned
the code “sudo cat /sys/kernel/debug/tegradc.1/edid”

which returned :

00 ff ff ff ff ff ff 00 1e 6d c7 5a 01 01 01 01
01 18 01 03 80 2c 19 78 ea 31 35 a5 55 4e a1 26
0c 50 54 a7 6a 80 71 4f 81 c0 a9 c0 81 00 95 c0
01 01 01 01 01 01 30 2a 40 c8 60 84 64 30 18 50
13 00 b8 fa 10 00 00 1e 00 00 00 fd 00 38 4b 1e
53 0f 00 0a 20 20 20 20 20 20 00 00 00 fc 00 4c
47 20 48 44 20 50 4c 55 53 0a 20 20 00 00 00 ff
00 0a 20 20 20 20 20 20 20 20 20 20 20 20 01 a4
02 03 1d f1 4a 84 04 03 01 12 12 13 13 13 13 23
09 07 07 83 01 00 00 65 03 0c 00 10 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
00 01 1d 00 72 51 d0 1e 20 6e 28 55 00 b8 fa 10
00 00 1e 8c 0a d0 8a 20 e0 2d 10 10 3e 96 00 b8
fa 10 00 00 18 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 c0

I can also see Ubuntu screen in he HDMI display.

Is there anything more I can do.

Awaiting for your reply and Thanks in Advance

Regards
AMITAVA

The information is useful. I’d like to start by verifying that this Jetson has previously had a successful use of the graphical mode login at some point using any monitor? Which version of L4T is flashed? See:

head -n 1 /etc/nv_tegra_release

If you paste the EDID data in here you can see what any user of EDID would know about the monitor:
http://www.edidreader.com/
…this data is valid.

It’s interesting that the LG has valid EDID now, but previously had given “NO EDID”. Please verify this: The LG previously had NO EDID, but after a new cable is used, it has the above EDID data?

Here are the modes reported (hopefully I didn’t misinterpret the data from the DELL instead of LG…I am assuming this is LG and that LG did not have EDID previously):

Format: 1280x720p   Field Rate: 59.94Hz/60Hz
Format: 720x480p    Field Rate: 59.94Hz/60Hz
<b>Format: 640x480p    Field Rate: 59.94Hz/60Hz</b>
Format: 720x576p    Field Rate: 50Hz
Format: 720x576p    Field Rate: 50Hz
Format: 1280x720p   Field Rate: 50Hz
Format: 1280x720p   Field Rate: 50Hz
Format: 1280x720p   Field Rate: 50Hz
Format: 1280x720p   Field Rate: 50Hz

Here is a list of Xorg’s “standard timings” (I read this directly out of Xorg source code used in R24.2.1). One of these timings should be the default when no EDID is found, although you won’t necessarily know which one:

720x400@70Hz
720x400@88Hz
<b>640x480@60Hz</b>
640x480@67Hz
640x480@72Hz
640x480@75Hz
800x600@56Hz
800x600@60Hz
800x600@72Hz
800x600@75Hz
832x624@75Hz
1024x768@87Hz (interlaced)
1024x768@60Hz
1024x768@70Hz
1024x768@75Hz
1280x1024@75Hz

Note that 640x480@60Hz is the only one which matches both standard timings and the monitor’s capabilities. This is the only mode which might “just work” without EDID or manual configuration.

It would be a bug if 640x480@60Hz does not work, and likely a bug that this was not chosen given that you now have EDID data. The question still remains as to whether the mode was mistakenly ignored (such as through EDID issues), or if the mode itself had other issues. I would guess that the mode works when chosen, and the bug was in falling back to a mode other than 640x480. Steps listed later with xrandr can test this.

I have a monitor here which has valid EDID data, but fails in text-only console mode with “scan too fast” where the console does not set a correct mode (but GUI does work). It too has “invalid panel compatible” in dmesg. I don’t have this set up with a completely working monitor so I can’t compare to see if this message goes away on completely functional monitors or not, but you may be able to get things working by manually running xrandr for 640x480@60Hz. Should this succeed, then you may be able to manually attempt some of the other resolutions (more work may be required since they are not standard modes). For those interested the dmesg comes from “arch/arm/mach-tegra/board-panel.c”, function “available_internal_panel_select”. I’m thinking perhaps the “of_device_compatible” test cases should include all modes of the “standard” timings from Xorg listed above.

For manual switching you need to know which display is referenced (the name). The HDMI connector should always default to “HDMI-0” on a developer board with no other video. xrandr won’t know this unless you set the environment variable “DISPLAY”…this is automatic if you log in through the GUI, but logging in via serial console will do the job if you do this prior to any commands (this associates HDMI-0 with the serial console):

export DISPLAY=:0

…now to force 640x480:

xrandr --output HDMI-0 --mode 640x480

Should that succeed with DISPLAY set to :0 and EDID existing, try any mode from the output of “xrandr” with no arguments. I have 1440x900, so I can use this as --mode.

Should EDID not exist you can still add timing data and then switch modes via xrandr, but adding the timing data may not always be trivial. First find out if existing modes will do the job for you.

Hello…

head -n 1 /etc/nv_tegra_release

which returned

R24 (release), REVISION: 1.0, GCID: 7164062, BOARD: t210ref, EABI: aarch64,

DATE: Tue May 17 23:37:30 UTC 2016

I confirm the after new cable EDID was available for LG monitor. It seems issue with HDMI cable
thanks for pointing out.

I tried with
export DISPLAY=:0
xrandr --output HDMI-0 --mode 640x480

but without any positive reply. Presently I’m plugging in HDMI after booting Jetson may be around 1 minute.

I’ve also noted the following error which comes in serial console after booting
[s]ubuntu@tegra-ubuntu:~$ [ 12.939505] tegra210_mixer tegra210-mixer: ASoC: hw_params() failed: -22
[ 12.946357] tegra-snd-t210ref-mobile-rt565x sound.27: ASoC: PRE_PMU: TX1 Transmit-MIXER1-1
Receive event failed: -22

Any more trial to be done. Thanks in advance

Regards
AMITAVA

I don’t know if it would help or not, but R24.2.1 is the current release, and many bug fixes exist versus the installed R24.1 you now have. It might be worth flashing.

Regarding sound…unless sound was set up I’d expect errors. It is also possible that any failure of correctly detecting video would also pose a problem for audio reported through EDID (speakers built in to an HDMI monitor)…but not enough is known about the audio failure note to say what the audio message relates to (the message probably is not useful until video is working, and even if video works, there is more than one audio path the message may refer to). It would be interesting to note though whether sound has worked via any HDMI device at any time (LG or DELL…or even USB audio devices).

On the xrandr 640x480 command, can you paste a copy of exactly what did show up on the command line?

Note that you can monitor dmesg via this (which works on newer installations, but won’t work on some of the older Ubuntu 14.04):

sudo dmesg --follow

…and you can monitor the Xorg log in real time via:

sudo tail -f /var/log/Xorg.0.log

…is there any output at all under command line, dmesg or Xorg.0.log as you run the xrandr command for 640x480 (even trivial output may mean something)? After running that command, if no monitor output occurs, can you try pulling the video cable for a moment and then plugging it back in (a few seconds should be enough…when EDID isn’t working this is something of a “poor man’s” hot plug event at the monitor end to tell the monitor itself to check for changes…perhaps the change to 640x480 worked, but the monitor did not notice the change and needs to be prompted to look for the signal settings again)?

Hello…
Sorry for the delayed reply.

Here are the errors showing during booting probably I’ve shared earlier

  1. Error at Booting Jetson TX1
  • Setting up X socket directories… [ OK ]
  • speech-dispatcher disabled; edit /etc/default/speech-dispatcher
    saned disabled; edit /etc/default/saned
  1. Error while executing export DISPLAY=:0 and xrandr --output HDMI-0 --mode 640X480

Invalid MIT-MAGIC-COOKIE-1 keyCan’t open display :0

  1. While executing sudo dmesg --follow and sudo tail -f /var/log/Xorg.0.log

Monitor goes blank even after repeated pull up of HDMI cable nothing happened. I need to recycle power to Jetson TX1 for Ubuntu screen.

Following are the onscreen error

ubuntu@tegra-ubuntu:~$ sudo tail -f /var/log/Xorg.0.log
[ 43.444] (II) NVIDIA(0): Setting mode “HDMI-0: nvidia-auto-select @1600x900 +0+0 {ViewPortIn=1600x900, ViewPortOut=1600x900+0+0}”
[ 43.835] (II) NVIDIA(0): Setting mode “HDMI-0: nvidia-auto-select @1600x900 +0+0 {ViewPortIn=1600x900, ViewPortOut=1600x900+0+0}”
[ 45.395] () NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 45.395] (
) NVIDIA(0): device LG Electronics LG HD PLUS (DFP-0) (Using EDID
[ 45.395] () NVIDIA(0): frequencies has been enabled on all display devices.)
[ 45.396] (–) NVIDIA(GPU-0): LG Electronics LG HD PLUS (DFP-0): connected
[ 45.396] (–) NVIDIA(GPU-0): LG Electronics LG HD PLUS (DFP-0): External TMDS
[ 45.397] (II) NVIDIA(0): Setting mode “HDMI-0: nvidia-auto-select @1600x900 +0+0 {ViewPortIn=1600x900, ViewPortOut=1600x900+0+0}”
[ 45.869] (II) NVIDIA(0): Setting mode “NULL”
[ 45.962] (II) NVIDIA(0): Setting mode “HDMI-0: nvidia-auto-select @1280x720 +0+0 {ViewPortIn=1280x720, ViewPortOut=1280x720+0+0}”
[ 537.587] (II) NVIDIA(0): Setting mode “HDMI-0: nvidia-auto-select @1280x720 +0+0 {ViewPortIn=1280x720, ViewPortOut=1280x720+0+0}”
[ 544.695] (
) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 544.697] () NVIDIA(0): device LG Electronics LG HD PLUS (DFP-0) (Using EDID
[ 544.699] (
) NVIDIA(0): frequencies has been enabled on all display devices.)
[ 544.722] (–) NVIDIA(GPU-0): LG Electronics LG HD PLUS (DFP-0): connected
[ 544.724] (–) NVIDIA(GPU-0): LG Electronics LG HD PLUS (DFP-0): External TMDS
[ 544.738] (II) NVIDIA(0): Setting mode “HDMI-0: nvidia-auto-select @1280x720 +0+0 {ViewPortIn=1280x720, ViewPortOut=1280x720+0+0}”
[ 545.203] (II) NVIDIA(0): Setting mode “HDMI-0: nvidia-auto-select @1280x720 +0+0 {ViewPortIn=1280x720, ViewPortOut=1280x720+0+0}”
[ 545.745] () NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 545.745] (
) NVIDIA(0): device LG Electronics LG HD PLUS (DFP-0) (Using EDID
[ 545.745] (**) NVIDIA(0): frequencies has been enabled on all display devices.)
[ 545.746] (–) NVIDIA(GPU-0): LG Electronics LG HD PLUS (DFP-0): connected
[ 545.746] (–) NVIDIA(GPU-0): LG Electronics LG HD PLUS (DFP-0): External TMDS
[ 545.746] (II) NVIDIA(0): Setting mode “HDMI-0: nvidia-auto-select @1280x720 +0+0 {ViewPortIn=1280x720, ViewPortOut=1280x720+0+0}”
[ 546.316] (II) NVIDIA(0): Setting mode “HDMI-0: nvidia-auto-select @1280x720 +0+0 {ViewPortIn=1280x720, ViewPortOut=1280x720+0+0}”

any more clue to try upon. Thanks in advance

Regards
AMITAVA

You can ignore the first error messages unless you’ve previously set up speech and an image scanner…very few people have this set up. Regardless, those errors will have no relation to video function.

Error #2, “Invalid MIT-MAGIC-COOKIE-1 keyCan’t open display :0”, is a reflection on a given user locking an X session (or failing to associate with an X session). If there is no session, then no temp file will be there and display open won’t be valid. Alternatively, if you try to manipulate a display from a different user than the one owning the display you’ll be rejected. This latter case might be if user ubuntu is running a display, but sudo is used to manipulate xrandr (which would mean root is manipulating ubuntu’s session…this isn’t allowed). So did the display not exist (e.g., nobody logged in to GUI or crashed GUI), or was the wrong user used to manipulate display through xrandr?

Messages on Xorg log show EDID was used. It is very odd that it looks like EDID used to set up the monitor succeeded…at least in the Xorg log.

Here is an experiment to try: Boot up, and after waiting, disconnect and reconnect the HDMI cable. Wait about 10 seconds, then run this via serial console:

sudo systemctl isolate multi-user.target
sudo systemctl isolate graphical.target

…see if the monitor starts locking onto a signal or shows anything at all.

unfortunately showing the following error

ubuntu@tegra-ubuntu:~ sudo systemctl isolate multi-user.target sudo: systemctl: command not found ubuntu@tegra-ubuntu:~

Regards
AMITAVA

Are you using the 32-bit user space on your rootfs? I was thinking all of the Ubuntu 16 would by default have systemctl (located at “/bin/systemctl”…maybe verify this with “ls /bin/systemctl”).

If actually missing and not using 32-bit user space I’d say something is wrong with the install.

As an alternative to systemctl try:

sudo telinit 3
# Wait about 10 seconds...
sudo telinit 5