hdmi output doesnt work in ubuntu 18.04

Hi all!

I have asus notebook (fx705dt, amd ryzen 7 + amd radeon rx vega 10 + nvidia geforce gtx 1650)

I tries these things (secure boot is disabled):

1- stock open source drivers

2- ubuntu-drivers devices (nvidia-driver-430)
then sudo ubuntu-drivers autoinstall
and then sudo apt install nvidia-430
and reboot, and then select into drivers configuration screen.

3- download driver from
http://www.nvidia.com/Download/index.aspx
select open source driver,
remove and purge nvidia driver
reboot
sudo bash NVIDIA-Linux-x86_64-430.09.run
and it stucks in 5% in>
Installing DKMS kernel module:
Building module (This may take a moment)

PS: In the same laptop I have partition with win10 and all works fine.

best regards !
nvidia-bug-report.log.gz (1.07 MB)
nvidia-bug-report-2.log.gz (1.07 MB)
nvidia-bug-report-3.log.gz (1.07 MB)
nvidia-bug-report-4.log.gz (1.1 MB)

this is tail of installing .run driver

-> An incomplete installation of libglvnd was found. All of the essential libglvnd libraries are present, but one or more optional components are missing. Do you want to install a full copy of libglvnd? This will overwrite any existing libglvnd libraries. (Answer: Install and overwrite existing files)
Will install libglvnd libraries.
Will install libEGL vendor library config file to /usr/share/glvnd/egl_vendor.d
-> Searching for conflicting files:
-> done.
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86_64' (430.09):
   executing: '/sbin/ldconfig'...
-> done.
-> Driver file installation is complete.
-> Installing DKMS kernel module:

The amd+nvidia combo needs config tweaks.
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Hi !
Thanks for your answer.

I installed again nvidia-driver-430 open source driver and run this bash.

I attached it :)

  • Please delete /etc/X11/xorg.conf
  • make sure the package nvidia-prime is installed (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • modify /usr/share/X11/xorg.conf.d/10-amdgpu.conf
    replacing only
Driver "amdgpu"

with

Driver "modesetting"
  • modify /usr/share/X11/xorg.conf.d/10-nvidia.conf
    adding
Option "PrimaryGPU" "Yes"

inside the OutputClass.
After reboot, you’ll the internal screen probably stays off but the external monitor should work due to this:
https://devtalk.nvidia.com/default/topic/1065551/linux/amd-ryzen-5-igpu-nvidia-gtx-1050-mobile-black-screen-driver-problem/post/5396043/#5396043
log in and enable the internal display using the control center.

hi, thanks again !

with the first part hdmi output works, but my primary screen (laptop screen) stucks in black.

I read the topic you link. But I have this response when I tried xrandr --auto… :

xrandr: Configure crtc 4 failed
X Error of failed request: BadValue (integer parameter out of range for operation)
  Major opcode of failed request: 140 (RANDR)
  Minor opcode of failed request: 21 (RRSetCrtcConfig)
  Value in failed request: 0x0
  Serial number of failed request: 56
  Current serial number in output stream: 56

Are you using Gnome? Does the external monitor show the login?
Please create and attach a new nvidia-bug-report.log in the current state.

I have ubuntu 18.04, that it uses gnome yes.

After installed it the login appears in my laptop only,and after login my laptop goes blank/black and the desktop only shows in hdmi output.

yhanks, it is uploading with new name: nvidia-bug-report-2.log.gz

another thing … in login screen, if I select GNOME WAYLAND the laptop screen works but not hdmi, and if i select only gnome (as it is by default) only works hdmi.

And I tried unplug hdmi and laptop screen continues in black

Wayland uses only the amd gpu so the external monitor which is connected to the nvidia gpu is unavailable. The gdm login seems to be running under wayland, ignore this for now.
Please add inside the OutputClass section of /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass.conf

Option "AllowEmptyInitialConfiguration" "true"

When logged in, can you simply start gnome control center and enable the internal monitor under devices->displays?

Hi , It continues equal.

I made this changes. the reboot.
then after login only works hdmi.
I enter to configuration, devices, displays.
I appears as “Mirror”… I change to extended displays, and when I click on apply it changes (as i see in background) to mirrored screens again… and when I accept it continues as the same.

=(

I am going to attach new nvidia report log as -3 file

Just noticed that nouveau is not blacklisted, please create
/etc/modprobe.d/blacklist-nouveau.conf

blacklist nouveau

and run
sudo update-initramfs -u
also disable wayland for gdm:
https://askubuntu.com/questions/975094/how-to-disable-wayland-in-17-10-in-gdm3-login-screen
and reboot.

thanks again.

No login appears in the hdmi monitor, but the laptop screens continues in blank

Please try enabling the internal screen and create a new nvidia-bug-report.log afterwards.

I attached new version of bug-report (4)

Also I attached screenshot of my “display options”.

thanks again !

IDK, but your setup looks kind of broken, you’re always running into

[     5.408] (EE) modeset(G0): failed to set mode: No space left on device

Which driver are you currently running, the one from .run installer? If so, please uninstall it using the --uninstall option, then reinstall the driver from repo.

mmmm

i will check it ;)

“no space left” is so strange, because it has 300gb free in linux partition hehe

IT WORKS !!!

You are my Jesus/Jebus/GOD !

Thanks thanks and thanks !!!

It works perfect. With or without hdmi connection.

I uninstalled .run driver, install driver from repo : apt install nvidia-driver-430 and reboot.

Amazing.

thanks and thanks again for all your help