Horizon 7.1 Unable to power on parent image - The amount of graphics resource available...

We have 3 NVIDIA Tesla M10 cards. One card in each of three Cisco UCSC-C240-M4S hosts. We are using Horizon 7.1. I have one pool with 5 VM’s in it. They are using the m10-2q profile.

I am unable to power on my parent image. I get the following error:
The amount of graphics resource available in the parent resource pool is insufficient for the operation.

I have tried changing the profile on the parent image to several other profiles but still unable to power on the VM and get same error message.

Also to note. Whenever I refresh or recompose this pool the VM’s struggle to startup. They error out with the same message a couple time before finally booting on the third.

I’m not sure if this is something I need to be asking VMware or NVIDIA so I figured I would start here.


you should change the consolidation policy witihin ESX:

„To improve virtual machine consolidation ratios, you can set the ESXi host to use consolidation mode. Edit the /etc/vmware/config file on the ESXi host and add the following entry:
vGPU.consolidation = "true"

By default, the ESXi host assigns virtual machines to the physical GPU with the fewest virtual machines already assigned. This is called performance mode. If you would rather have the ESXi host assign virtual machines to the same physical GPU until the maximum number of virtual machines is reached before placing virtual machines on the next physical GPU, you can use consolidation mode.

I actually discovered the root issue. Each host graphics configuration was set to Shared instead of Shared Direct. Making this switch resolved the issue. Thanks for reply - I will use this suggestion too.

Hi - I am getting the same "amount of Graphics resource available" error.
I just upgraded some ESXi hosts to Esxi 6.0 Patch 5 ( i.e. rev 5572656 )… All my K2 machines will not turn on.
I am running Vcenter 6.0.0 3018524. Thus i do not see those options for shared direct as im not on vCenter 6.5.

Any thoughts ?

THis seems to be an issue with VMWare patch.
Please contact VMWare for a solution.