How can i install ofed driver for Connect-X6 under openSUSE LEAP 15.3?

I got error message during the installation
The current MLNX_OFED_LINUX is intended for sles15sp3

Hi heinz_zhang,

Thank you for posting your query on our community.

Based on the Release Notes of latest OFED , OpenSUSE 15.3 is listed under Community OS based on the support Matrix —>

OpenSUSE 15.3 AArch64 - Community (error) (error) (error) (error) (error) (error) (error)
ppc64le - Community (error) (error) (error) (error) (error) (error) (error)
x86_64 5.3.18-150300.59.43-DEFAULT Community (error)

Please confirm you are Installing the OFED based on procedure described for Community OS →


Hi Namrata,

many thanks for your help!
After reading the docs, I have aonther questions.

  1. is OpenSUSE 15.3 only supported by community driver, and only SRC, no compiled binary driver was provided, is it true?
  2. according to the list, NFSoRDMA is not supported.
    Does it mean even after I installed ConnectX 6 -DX on it, OpenSUSE 15.3 itself still not support NFSoRDMA?
    Actually this is the purpose I would like test transfer speed via NFSoRDMA.

Thanks again for your time during holidays.

Hi heinz_zhang,

For question 1, based on the Release Notes link shared previously, it states the following:

Overall, the following should be noted when running OFED on the community-supported operating systems:

  • NVIDIA will perform sanity testing of OFED on community supported OSs
  • NVIDIA will declare which kernel versions were tested (min/max), based on mainstream kernel ( versions
  • NVIDIA will not ship binaries/installation packages for community-supported OSs
  • Customers will use source code of OFED and build guidance and will need to build their own binaries & installation packages**

For question 2, as listed , for OpenSUSE 15.3 and using MLNX OFED, NFSoRDMA is not supported. If you decide to use Inbox driver that comes with OS, questions regarding support of specific functionality with Inbox driver should be addressed with OS vendor.


Hi Namrata,

I need you help again. I tried to download the community version
and run ./ --all
installation failed during mlnx-ofa_kernel 5.7 RPM
I tried to parse installation logs but only found following errors:

cp: target ‘/var/tmp/OFED_topdir/BUILDROOT/mlnx-ofa_kernel-5.7-OFED.’ is not a directory
error: Bad exit status from /var/tmp/rpm-tmp.f3TDTd (%install)

RPM build errors:
user builder does not exist - using root
group dip does not exist - using root
user builder does not exist - using root
group dip does not exist - using root
Bad exit status from /var/tmp/rpm-tmp.f3TDTd (%install)

Do you have any idea to procceed?

many thanks!