How Can I make the Quadro M1200 Mobile works on Dell Precision 5520 under Centos/RHEL 7.5

Hey, All:
I have a Dell Precision 5520 which have an extra Quadro M1200M card (and what is that?) and I’ve install Centos 7.5 on it to try some cuda development. But I have tried my best while failed to make the nvidia card works on that OS. the pre-installed Ubuntu 16.04 of DELL sucks and they provided a “dell-nvidia-367.44-rhel_7.3.el7.x86_64” on DELL driver downloading site which can not worked at all on 7.5. I have tried to downloading driver on Nvidia website with “Quadro Notebook M1200”, “NVIDIA-Linux-x86_64-390.77.run” and installed by blacklist the nouveau, it failed also.

The Informations are:
1) graphical devices:
[marshall@bogon ~]$ lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation HD Graphics P630 (rev 04)
01:00.0 3D controller: NVIDIA Corporation GM107GLM [Quadro M1200 Mobile] (rev a2)
2) kernel information:
[marshall@bogon ~]$ uname -a
Linux bogon 3.10.0-862.9.1.el7.x86_64 #1 SMP Mon Jul 16 16:29:36 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
3) rhel version:
[marshall@bogon ~]$ lsb_release -a
LSB Version:	:core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Distributor ID:	CentOS
Description:	CentOS Linux release 7.5.1804 (Core) 
Release:	7.5.1804
Codename:	Core
4) blacklist:
[marshall@bogon ~]$ cat /etc/modprobe.d/nvidia-installer-disable-nouveau.conf 
# generated by nvidia-installer
blacklist nouveau
blacklist lbm-nouveau
#options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off
 5) nvidia driver on cuda repo:
[marshall@bogon ~]$ sudo dnf list xorg-x11-drv-nvidia-devel.x86_64
Last metadata expiration check: 3:00:31 ago on Fri 27 Jul 2018 03:37:17 PM CST.
Available Packages
xorg-x11-drv-nvidia-devel.x86_64               1:396.37-1.el7               cuda
 what is this? the LTS *.run download from nvidia driver site is "NVIDIA-Linux-x86_64-390.77.run", the version is different, but none of this works.

 6) my defult grub setting:
[marshall@bogon ~]$ cat /etc/default/grub 
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="gfxterm"
GRUB_CMDLINE_LINUX="crashkernel=auto rd.lvm.lv=centos/root rd.lvm.lv=centos/swap video=eDP-1:1920x1080@60 rdblacklist=nouveau rhgb quiet"
GRUB_DISABLE_RECOVERY="true"
GRUB_GFXMODE=1920x1080,1024x768,640x480
 7) the default xorg on Centos 7.5 is strange, the configure file seems like a little evil mouse which want to go everywhere:
[marshall@bogon ~]$ ls /etc/X11/xorg.conf.d/
00-keyboard.conf
[marshall@bogon ~]$ ls /usr/share/X11/xorg.conf.d/
10-evdev.conf   50-synaptics.conf  50-wacom.conf
10-quirks.conf  50-vmmouse.conf
 when I finished to install nvidia driver (by .run file), it add an nvidia-output-class.conf under /usr/share/X11/xorg.conf.d/ and startx will fail with "(EE) can not load nouveau" (I have blacklist it!!!)
 After I use "nvidia-xconfig -a", it will generate a xorg.conf under /etc/X11/, which provide "(EE) can not find Monitor, (EE) can not find device"

 So my question is: How can I make it work with cuda. this problem takes me about a week and I hope someone who can kindly help me with that.
 Thanks alot again.

It’s an Optimus laptop which needs extra config. Ubuntu does that, Centos not. See this post for help, it also has a link to a user created script that creates the necessary config:
https://devtalk.nvidia.com/default/topic/1022670/linux/official-driver-384-59-with-geforce-1050m-doesn-t-work-on-opensuse-tumbleweed-kde/post/5203910/#5203910

Thanks Alot, I’ve tryed install the .run file first, then mannually write a new xorg.conf file under /etc/X11 then add optimus.desktop as your said, it works, thanks alot then.