How to change Realtek 8852Be bluetooth(usb) M2E_BT_DISABLE_N gpio

Because you need to use spi3, you need to change the M2E_BT_DISABLE_N pin

Expected to modify the pin position to GPIO17

modify tegra234-mb1-bct-gpio-p3701-0000-a04.dtsi

			gpio-output-high = <
				//TEGRA234_MAIN_GPIO(Y, 0)		
				TEGRA234_MAIN_GPIO(P, 4)

I can see bt devices

but use command hcitool scan ,can’t see any bt devices

So modify the M2E_BT_DISABLE_N pin and what else needs to be modified?

你可以參考xavier nx底下這份檔案裡面的gpio-hog sample幫你的GPIO寫一個

hardware/nvidia/platform/t19x/common/kernel-dts/t19x-common-platforms/tegra194-comms.dtsi

This should not require adding a new control BT_DISABLE pin!
I changed the original BT_DISABLE pin position…

I searched the kernel source code, about GPIO TEGRA186_MAIN_GPIO(Y, 0), but there is no related BT_DISABLE pin setting

So I don’t know if BT_DISABLE needs additional settings?

I mean you should add gpio hog for your pin… there is no one already modified this for you.

Sorry to say that… your comment in English is hardly to understand. If it is okay for you, you could directly tell your comment in Chinese.

我的意思是你可以自己加一個gpio hog給你要改的那根pin. 沒有人已經幫你寫好…

另外抱歉這樣說, 但你的英文表達真的很不清楚, 可以直接用中文講你想說的就好

後來發現 與 CONFIG_BT_HCIBTUSB 有關!
拿掉這個 8852be 的 BT 就可以正常…

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.