How to change the IPoIB mode of Infiniband Interface usring Mellanox ConnectX-4.


Changing the mode of an InfiniBand interface by echoing either connected or datagram to /sys/class/net/ibN/mode is not supported.

Modifying the /etc/infiniband/openibd.conf configuration file also does not work.

driver version:MLNX_OFED_LINUX-4.2-

[root@localhost ~]# flint -d /dev/mst/mt4115_pciconf0 q

Image type: FS3

FW Version: 12.21.2010

FW Release Date: 27.11.2017

Product Version: 12.21.2010

Rom Info: type=PXE version=3.5.305 cpu=AMD64

Description: UID GuidsNumber

Base GUID: 7cfe9003004405e8 4

Base MAC: 00007cfe904405e8 4

Image VSD: N/A

Device VSD: N/A

PSID: MT_2190110032

Security Attributes: N/A

Hi zhuqing kuang,

On recent version of OFED Enhanced IPoIB is turned on by default , Which prevents using CM .

Please try to to disable Enhanced IPoIB:

  1. Disable “ipoib_enhanced”:

#vi /etc/modprobe.d/ib_ipoib.conf

Add the following entry:

options ib_ipoib ipoib_enhanced=0

  1. Stop and start openibd service:

#/etc/init.d/openibd stop

#/etc/init.d/openibd start

  1. Verify parameter is disabled: (The value should be 0)

#cat /sys/module/ib_ipoib/parameters/ipoib_enhanced

  1. Verify the mode:

#cat /sys/class/net/ib0/mode



Thank you very much. The problem has been solved using your method.