Ubuntu Connected mode not working

,

Hello I have Connectx-4 VPI (2 port) , I install OFED for Ubuntu and I would like to change port to Connected mode, I done changes in interface file but when I restarted I get :

ib1: Setting Connected Mode failed, not supported by this device

Can somebody can help me with this ?

From what I can tell this no longer works with Ubuntu 18.04. When I try this solution, during boot I get:

[ 4128.198929] ib_ipoib: unknown parameter ‘ipoib_enhanced’ ignored

I tried with the native 18.04 drivers and after installing mlnx-en-4.4-2.0.7.0-ubuntu18.04-x86_64.tgz

Hi Adam,

In order to set up connected mode, please try first disabling IPoIB enhanced mode to do so please follow the procedure below:

  1. Disable “ipoib_enhanced”:

#vi /etc/modprobe.d/ib_ipoib.conf

Add the following entry:

options ib_ipoib ipoib_enhanced=0

  1. Stop and start openibd service:

#/etc/init.d/openibd stop

#/etc/init.d/openibd start

  1. Verify parameter is disabled: (The value should be 0)

#cat /sys/module/ib_ipoib/parameters/ipoib_enhanced

  1. Verify the mode:

#cat /sys/class/net/ib0/mode

Once disabled please go ahead and enable connected mode.

Thanks,

Samer