How to disable low-latency encode mode in Gstreamer?

Hi,

As the answer at https://devtalk.nvidia.com/default/topic/1004948/jetson-tx1/low-latency-h-w-encoding-from-camera/post/5131479/#5131479
Low-latency is on by default.
But I want to encode normally, without low-latency. I’m using Gstreamer. So Is there any option on Gstreamer to disable the low-latency?

Hi thaiconghuan,
Any issue you have seen with default encoder configuration? We can give you suggestion.

You may also check [Supported H.264/H.265 Encoder Features with Gstreamer-1.0] in user guide:
https://developer.nvidia.com/embedded/dlc/l4t-accelerated-gstreamer-guide-28-2-ga

Hi Danelll,

Thank for prompt reply

Any issue you have seen with default encoder configuration? We can give you suggestion.
Because I want the best quality within certain bitrate. And I think that the low-latency mode will reduce the quality.

I have used the command

gst-launch-1.0 filesrc location=/home/nvidia/workspace/yuv/input.yuv ! videoparse width=1920 height=1080 framerate=30/1 format=i420 ! omxh264enc control-rate=2 iframeinterval=30 bitrate=12000000 qp-range="-1,-1:-1,-1:-1,-1" EnableTwopassCBR=false profile=8 ! ‘video/x-h264, stream-format=(string)byte-stream’ ! queue ! filesink location=output.264 -e

Do changing the EnableTwopassCBR=true preset-level=3 give me a better quality video? Or what is the best encoding option at a certain bitrate?

Please configure preset-level. Below is comparison for your reference:
https://devtalk.nvidia.com/default/topic/932754/jetson-tx1/more-clarity-on-h-265-encode-parameters-/post/5037363/#5037363