How to disabled Uart0's debug message?

Hello. I need help.

TX2I uses Uart0 as ttyS0.

However, ttyS0 is also used as a console port.

When communicating with ttyS0, debug message is output.

I want to make this debug message not come out.

Is there a way to disable debug message?

hello bh.yim,

please check developer guide, you should check Disable Console over UART for reference.

Hello. Jerry Chang.

I referred to the developer guide as you told me, but it has not been solved.

The kernel debug message was lost in that way.
However, the bootloader debug message is still output.

Is there any other way?

Thank you.

This is a bit old, but should probably be valid:

That URL is about changing serial console to a new UART, but you could just leave out the new UART and use the part to stop the original UART from being a console.

What you’re running into is that Linux and the boot content are separate programs. Disabling this from Linux can succeed, but messages from earlier boot stages (before Linux loads) could still use the serial console. Device tree is part of configuration of both Linux and the earlier boot content, and so you’ll find references to disable/reenable UARTs from that URL via device tree.