How to force Nvidia Jetson Nano USB Camera Resolution to 1080P

Pixel format changing to YUYV 640x480 every time I run Deepstream App with USB camera as a source.

I’d like to run source @1080P. How can I force deepstream app to use MJPEG or H.264 @1920x1080? Is there a way to change these settings in the deepstream app /config files?

Nvidia Jetson Nano
Jetpack 4.3
Deepstream 4.0.2

Camera Information:

    ioctl: VIDIOC_ENUM_FMT
    Index       : 0
    Type        : Video Capture
    Pixel Format: 'MJPG' (compressed)
    Name        : Motion-JPEG
            Size: Discrete 1920x1080
                    Interval: Discrete 0.033s (30.000 fps)
            Size: Discrete 1280x720
                    Interval: Discrete 0.033s (30.000 fps)
            Size: Discrete 640x480
                    Interval: Discrete 0.033s (30.000 fps)
            Size: Discrete 640x360
                    Interval: Discrete 0.033s (30.000 fps)

    Index       : 1
    Type        : Video Capture
    Pixel Format: 'YUYV'
    Name        : YUYV 4:2:2
            Size: Discrete 1280x720
                    Interval: Discrete 0.100s (10.000 fps)
            Size: Discrete 640x480
                    Interval: Discrete 0.033s (30.000 fps)
            Size: Discrete 640x360
                    Interval: Discrete 0.033s (30.000 fps)

    Index       : 2
    Type        : Video Capture
    Pixel Format: 'H264' (compressed)
    Name        : H.264
            Size: Discrete 1920x1080
                    Interval: Discrete 0.033s (30.000 fps)
            Size: Discrete 1280x720
                    Interval: Discrete 0.033s (30.000 fps)
            Size: Discrete 640x480
                    Interval: Discrete 0.033s (30.000 fps)
            Size: Discrete 640x360
                    Interval: Discrete 0.033s (30.000 fps)

Thanks.

Hi,
Please try

$ gst-launch-1.0 v4l2src device=/dev/video0 ! image/jpeg,width=1920,height=1080,framerate=30/1 ! jpegparse ! nvv4l2decoder mjpeg=1 ! nvoverlaysink sync=false

Hi DaneLLL,

Thanks for replying back. I’ve tried your suggestion and that worked just fine. How can I force deepstream-app to use MJPG? Is there any specific parameter that I should use?

Thanks.

Hi ,
MJPEG decoding is not supported in deepstream-app. You would need to refer to deepstream-image-decode-test. Please check

deepstream-5.0/sources/apps/sample_apps/deepstream-image-decode-test/README

Ok. Thanks.