How to install CMake 3.8 ++ in Jetson Tx2?

I have to run program that requires minimum CMake 3.8 . Unfortunately using

sudo apt-get install cmake

will only install CMake 3.5

I tried to follow this steps that works very well in my another computer https://askubuntu.com/questions/829310/how-to-upgrade-cmake-in-ubuntu . But doesn’t work in Jetson TX2. Is there any way to install the latest version of CMake from https://cmake.org/download/ ?

Looks like there’s no any install package for ARM arch. You may need to download the source to build it manually.

Thanks for the confirmation, I followed steps to install CMake from source from this site : https://askubuntu.com/questions/829310/how-to-upgrade-cmake-in-ubuntu (accepted answer)

It works well with my PC, but doesn’t work in Jetson. When I type cmake --version it said it couldn’t find the cmake. Does Jetson requires different step from usual ubuntu to install cmake?

That comment is run the install package for x86 not for ARM.

Hi ivandi5hj8,

Our next release (soon) is with ubuntu 18.04 on which you can install 3.10.2 via apt-get.

@ivandi5hj8
You should be able to download the source from below and build it on tegra.

  1. un-tar it.
  2. ./config # You may need install g++ and perl by apt-get install
  3. sudo make install

https://cmake.org/files/v3.8/cmake-3.8.2.tar.gz

Thanks a lot, solved my problem