How to record the screen of the Jetson TX1 Ubutnu14.04.

Hi,

I would like to measure the screen of the Jetson TX1 Ubuntu 14.04.
Does anyone know is there any tools to install it on Jetson TX1 Ubuntu 14.04 OS.

Thanks!

Can you be more specific…do you want specific screen shots, physical DPI resolution, X server resolution, so on?

You can leverage gstreamer https://devtalk.nvidia.com/default/topic/1001636/

Hi,

The idea is that, I would like to recored the screen like in normal linux OS.
For example, in the screen I would like to show the simulation and memory usage in
one screen, would that be possible. Is there any command available or software I need to install it on th e Jetson TX1 ubuntu 14.04.

Thanks!

Are you talking about a single screen capture image? Or a video? I suppose gimp might be overkill, but this is what I tend to use on my desktop PC. More information on what kind of output format you want would be useful (e.g., video, png, jpg, mp3, mp4, ogg).

Hi Linuxdev,

Thanks! as you might known already Jeston TX1 has ARM Cortex CPU and I am running Ubuntu 14.04 on it.
For example, in normal Intel CPU Deskop Ubuntu xx.xx we can use Simple Screen Recorder or Green recorder, etc,. I would like to find something like that for Jetson TX1 to record my screen as a video. Output format can be any as long as I can play them as video in any video player.

Thanks!

You may try this gstreamer pipeline (not tested on TX1, but it works on TX2/R28.1):

gst-launch-1.0 -v ximagesrc use-damage=0 ! nvvidconv ! 'video/x-raw(memory:NVMM),alignment=(string)au,format=(string)I420,framerate=(fraction)25/1,pixel-aspect-ratio=(fraction)1/1' ! omxh264enc !  'video/x-h264,stream-format=(string)byte-stream' ! h264parse ! matroskamux ! filesink location=screen.mkv

It will produce a file screen.mkv that you can play from Ubuntu video player. It is compressed in H264, so that it doesn’t fill the disk very fast, but it is better to record on an external disk.

You may have a terminal in gui running

sudo /home/nvidia/tegrastats

for giving resources usage stats.

gst-launch-1.0 -v ximagesrc use-damage=0 ! nvvidconv ! 'video/x-raw(memory:NVMM),alignment=(string)au,format=(string)I420,framerate=(fraction)25/1,pixel-aspect-ratio=(fraction)1/1' ! omxh264enc ! 'video/x-h264,stream-format=(string)byte-stream' ! filesink location="test.h264" -e

source : https://devtalk.nvidia.com/default/topic/1001636/

Hi Honey_Patouceul and Andrey1984,

I will try those commands in the morning when I have a access to the card. However I do not have TX2; I hope it might work with TX1.

Thanks!

TX1 and TX2 are very much alike. If you use R28.1, then they even use the same rootfs (which is Ubuntu 16.04). If it works on one, then chances are it works on the other.

Hi all,

Some how non of those commands worked for me, from the error what I got, and that leads to another link and that worked well in my case.

gst-launch -e ximagesrc ! ffmpegcolorspace ! nv_omx_h264enc ! mp4mux ! filesink location=video.mp4

Thanks!

Looks you are using gstreamer-0.10…
Are you running an old L4T ? You can check your L4T version with:

head -n 1 /etc/nv_tegra_release

Current L4T version for TX1 is R28.1.

Hi Honey_Patouceul,

I have installed this yesterday:

sudo apt-get install gstreamer1.0-tools gstreamer1.0-alsa gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav
sudo apt-get install v4l-utils

And this is the output that I get from the command you specified it.

ubuntu@tegra-ubuntu:~$ head -n 1 /etc/nv_tegra_release
# R23 (release), REVISION: 1.1, GCID: 6258892, BOARD: t210ref, EABI: hard, DATE: Mon Nov  9 21:23:18 UTC 2015

Should I upgrade my gstreamer, if so could you please guide me to update it.

Thanks!

Seems you may like to upgrade your L4T release from R23 to R28.1

You’re indeed running a very old L4T…I think R23.1.1 was still a 32 bits userland.
You cannot upgrade more gstreamer-1.0. The missing thing is probably nvidia omx plugins, but you would get these only with a more recent L4T.

You may upgrade to R28.1 by reflashing with JetPack3.1 from host PC.
Any data you have on jetson would be lost, so be sure to backup anything important before.
Note that the binaries you’ve built on R23.1 would probably not run on more recent 64bits L4T, so you would have to rebuild on new L4T.

Hi Andrey1984 and Honey_Patouceul,

Thanks for clear information. Actually I wanted to install R28.1 from the beginning , a month ago.
But somehow this JetPack 3.x says, its on the developers stage and only supports the TX2.

From above website it says, its in production stage and can support TXX, that is good!

Is there any clear instruction for the upgrading from my Host PC.

Thanks!

  1. backup data
  2. flash OS
  3. upload data back
    Some instruction found http://docs.nvidia.com/jetpack-l4t/#developertools/mobile/jetpack/l4t/3.2rc/jetpack_l4t_install.htm%3FTocPath%3D_____3
    it is for 3.2 though

JetPack-3.2 has only R28.2-DP for TX2, but JetPack-3.1 should support R28.1 on TX1.

However, the instruction, the installation instruction seems the same for all versions:
http://docs.nvidia.com/jetpack-l4t/index.html#developertools/mobile/jetpack/l4t/28.1/jetpack_l4t_install.htm

Hi Andrey!

Here is info says for all TXX:

http://docs.nvidia.com/jetpack-l4t/index.html#developertools/mobile/jetpack/l4t/3.0/jetpack_l4t_install.htm

Can I install the Ubuntu OS 64-bit on aarch64 TX1. Is it feasible or not.
Right now I have Ubuntu OS 32-bit.

Thanks!