How to recover from the error GstRTSPSrc:source: streaming stopped, reason error (-5)

• Hardware Platform: Jetson nx
• DeepStream Version: v6.1.1
• JetPack Version: 5.0.2
• TensorRT Version:
• Issue Type: questions

Hi all,
I am using nvstreammux to connect multiple streams in deepstream. When one of the streams becomes unstable, I receive the error: “Error: gst-stream-error-quark: Internal data stream error. (1): gstrtspsrc.c(6057): gst_rtspsrc_loop (): /GstPipeline:pipeline7/GstURIDecodeBin:source-bin-01/GstRTSPSrc:source: streaming stopped, reason error (-5)”. How can I recover this video stream without restarting the pipeline? I have tried stopping the stream and recreating the uridecodebin, but the video stream still does not recover. My code is based on the example at deepstream_python_apps/ at master · NVIDIA-AI-IOT/deepstream_python_apps · GitHub.

We have c/c++ sample of reconnecting for RTSP streaming in deepstream-app sample. You can refer to it and implement with python by yourself.

I have looked at the deepstream-app related code and tried to use deepstream-app to pull 2 RTSP video streams, but when the video stream is unstable, deepstream-app does not try to reconnect.

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

In [source] group, the “type” should be 4(RTSP) but not 3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.