How to revert back to gstreamer 1.14.5

I tried updating gstreamer to 1.16.3 via gst-install (newest JetPack 4.5, unminified) and it compiled and installed a somewhat working version. As there seem to be some incompatibilities with nvidia proprietary functions I would like to revert back to 1.14.5. While gst-installmade a backup and printed out the instructions on how to restore the previous version this does not seem to work as expected.

Whenever I do tar xPf /root/gst-1.1.0-20210130_110429.tar.gz (which is the 1.14.5 backup) and do gst-inspect-1.0 --version directly afterwards it prints out:

gst-inspect-1.0 version 1.14.5
GStreamer 1.14.5

But after some time when I check the version again it suddenly (and without me doing anything) states:

gst-inspect-1.0 version 1.14.5
GStreamer 1.16.3

I already tried to compile 1.14.5 with gst-install but it fails on plugins-bad. Uninstalling gstreamer packages via APT and reinstalling them does not fix this as well.

Any idea how I can cleanly & permanently revert to 1.14.5?

Not sure if it helps, but you can try to clean the cache:

$ rm .cache/gstreamer-1.0/registry.aarch64.bin
1 Like

Thanks @DaneLLL I will check if that helps and report back

Cleaning the cache seems to have resolved the issue ;) Running for ~18h now without switching to 1.16.3

@DaneLLL Need to withdraw the solution mark, sadly enough. Had it happening again over the last 2 days. It seems that it “reverts” itself when I use apt-get. 2 days ago I compiled gentrans-plugins which I was missing some packages for and just now I did an apt-get update && apt-get dist-upgrade and it reverted as well.

You may clean the cache again and see if it helps. Or re-flash it to get a clean system.