How to run tensorflow-gpu testing for NV 2080 Super card?

Hi All,
At the same platform, the Nvidia 2080 Super card can’t run tensorflow-GPU, but the Nvidia 2080Ti can do.

On the Ubuntu 18.04.1 LTS. I have been successfully established test environment for tensorflow-gpu with NV2080 Super card (install cuda_10.0.130_410.48_linux.run + cudnn-10.0-linux-x64-v7.4.2.24 + Anaconda3-5.2.0-Linux-x86_64 + tensorflow-gpu1.13.1 ),but running “python tf_cnn_benchmarks.py --num_gpus=1 --batch_size=64 --model=resnet50 --variable_update=independent --local_parameter_device=gpu”, the system occurred error.The model=inception3 / alexnet / vgg16 has the same issue. If insert 2080Ti on this platform, it can successfully running.

I have tried on the Ubuntu 16.04.4 LTS, it has the same issue.

File “/root/anaconda3/envs/tensorflow/lib/python3.6/site-packages/tensorflow/python/ops/nn_ops.py”, line 234, in call
name=self.name)
File “/root/anaconda3/envs/tensorflow/lib/python3.6/site-packages/tensorflow/python/ops/nn_ops.py”, line 1953, in conv2d
name=name)
File “/root/anaconda3/envs/tensorflow/lib/python3.6/site-packages/tensorflow/python/ops/gen_nn_ops.py”, line 1071, in conv2d
data_format=data_format, dilations=dilations, name=name)
File “/root/anaconda3/envs/tensorflow/lib/python3.6/site-packages/tensorflow/python/framework/op_def_library.py”, line 788, in _apply_op_helper
op_def=op_def)
File “/root/anaconda3/envs/tensorflow/lib/python3.6/site-packages/tensorflow/python/util/deprecation.py”, line 507, in new_func
return func(*args, **kwargs)
File “/root/anaconda3/envs/tensorflow/lib/python3.6/site-packages/tensorflow/python/framework/ops.py”, line 3616, in create_op
op_def=op_def)
File “/root/anaconda3/envs/tensorflow/lib/python3.6/site-packages/tensorflow/python/framework/ops.py”, line 2005, in init
self._traceback = tf_stack.extract_stack()

Nvidia 2080 super log.txt (27.9 KB)

Nvidia 2080 Ti log.txt (12.2 KB)

Please refer to logfile.

You’ll need a newer driver for 2080 Super

The 410.48 driver bundled with

(install cuda_10.0.130_410.48_linux.run

won’t work with 2080 super.

Install the latest driver for 2080 super from http://www.nvidia.com/drivers

Then run the cuda_10.0.130_410.48_linux.run installer, but select “no” when prompted for driver install.

That setup should work on either card.

Hi Robert,

After installed the latest driver (NVIDIA-Linux-x86_64-430.40.run) under Ubuntu 18.04.1 or Ubuntu 16.04.4, but the tensorflow-gpu still don’t run for 2080 Super.

Test environments as below:

  1. Ubuntu 18.04.1 LTS:NVIDIA-Linux-x86_64-430.40.run + cuda_10.0.130_410.48_linux.run + cudnn-10.0-linux-x64-v7.4.2.24 + Anaconda3-5.2.0-Linux-x86_64 + tensorflow-gpu1.13.1

  2. Ubuntu 16.04.4 LTS:NVIDIA-Linux-x86_64-430.40.run + cuda_10.0.130_410.48_linux.run + cudnn-10.0-linux-x64-v7.4.2.24 + Anaconda3-5.2.0-Linux-x86_64 + tensorflow-gpu1.13.1

  3. Ubuntu 16.04.4 LTS:NVIDIA-Linux-x86_64-430.40.run + cuda_9.0.176_384.81_linux.run + cudnn-9.0-linux-x64-v7 + Anaconda3-5.2.0-Linux-x86_64 + tensorflow-gpu1.14.0

In addition, I have tried to change the NV driver version, but it’s still not valid.(eg: NVIDIA-Linux-x86_64-415.27.run / NVIDIA-Linux-x86_64-418.56.run / NVIDIA-Linux-x86_64-430.14.run / NVIDIA-Linux-x86_64-430.26.run )

Thanks.

2080Superlog_cuda9.0_16.04.txt (29.4 KB)
2080Superlog_cuda10_16.04.txt (29.5 KB)
2080Superlog_18.04.txt (20.7 KB)

The CUDA install in 2080Superlog_18.04.txt looks fine now. You may need to use the latest cudnn version.