Tensorflow with RTX 2070 Super

Hello everyone,

I would like some help as I am not sure if RTX 2070 Super has the compatibility to work with tensorflow yet. I have tried installing the necessary packages but it seems like when running some examples or an architecture I am working on only the CPU is being used.

I have been able to check that the architecture I am trying to train can work with RTX 2070 on 410.93 drivers and tensorflow-gpu 1.11.0 but trying to do that I get no display as I presume the 410.93 drivers are not compatible with RTX 2070 Super. By using the 430.34 driver and tensorflow-gpu 1.14 the RTX 2070 Super is not detected by either using tf.test.is_gpu_available or tf.test.gpu_device_name or running sess = tf.Session(config=tf.ConfigProto(log_device_placement=True)).

Thanks for the help.

Are you running on Linux or Windows? Also, are you obtaining TensorFlow via pip install?

If using Docker containers is an option. Our NGC containers are built to support our latest GPUs. (see https://www.nvidia.com/en-us/gpu-cloud/containers/)

Hello nluehr,

Thank you for taking the time to help me. I am currently running Linux and have obtained TensorFlow via pip install.

I was not using Docker as I am not quite sure if they work with Mask RCNN which is the architecture I am trying to train.

As you have noted already, the 410.xx drivers are too old to support RTX 2070 GPUs. However, newer drivers, such as 430.34, will continue to work with older CUDA applications like Tensorflow 1.11.

That said, TensorFlow not detecting the GPU at all probably points to a more general platform issue and is probably not related to the TF version. What output do you see if you run nvidia-smi? If the RTX 2070 is list there, can you try to build and run the device query CUDA sample. https://github.com/NVIDIA/cuda-samples/tree/master/Samples/deviceQuery.

Hello nluehr,

Thank you for your reply. This is what I see when I run nvidia-smi:


I think the nvidia drivers are installed correctly.
This is the result of me trying to build and run the device query for a CUDA sample.


Please do not hesitate to ask me to do anything else in order to resolve this issue.

The screen shots show that you have built the examples. Please also provide the output from executing cuda-samples/bin/x86_64/linux/release/deviceQuery.

Also, what version of cudnn and the cuda toolkit do you have installed? Since you are using the pip installed TF, I think you’ll want CUDA 10.0 and cudnn 7.4.1.

I am in the same boat as OP, I can’t get tensorflow-gpu and cuda working together, when using the 2070Super (on a fresh ubuntu 18.04 install). I tried the official tensorflow-gpu guide, manual cuda installation, via apt, via conda and some unholy amount tinkering.

On a previous GTX 1080 system it worked out of the box.

Although nvidia-smi and tensorflow detect the 2070Super, when running a model everything fails with the warning that cudnn implementation is not found (I’m using cuda 10.0 and the respective newest cuda 10.0 cudnn libraries) and I did not find one person running tensorflow-gpu and the 2070Super successfully together. The only thing I found was this thread…

rtx2070, What version of cudnn are you using? Can you try running with tf-nightly and cudnn 7.6.2?

how about now ? Is everything ok with 2070super?Because I am considering buy rtx2070super for tensorflow. Please tell me if you have solbed this problem,thanks very much!

All the packages I used for my latest test:
Driver Version:

430.40

Tensorflow Version (pip install tf-nightly-gpu-2.0-preview):

import tensorflow as tf
print(tf.__version__)
2.0.0-dev20190731

CUDA 10.0:

cuda-repo-ubuntu1804-10-0-local-10.0.130-410.48_1.0-1_amd64.deb
cuda-repo-ubuntu1804-10-0-local-nvjpeg-update-1_1.0-1_amd64.deb (patch)

cuDNN v7.6.2 (July 22, 2019), for CUDA 10.0

libcudnn7_7.6.2.24-1%2Bcuda10.0_amd64.deb
libcudnn7-dev_7.6.2.24-1%2Bcuda10.0_amd64.deb

Still I’m getting errors like these:

UnknownError:  Failed to get convolution algorithm. This is probably because cuDNN failed to initialize, so try looking to see if a warning log message was printed above.

or jupyter kernel crashes…

Edit:
I encountered the same behavior when using the official tensorflow docker container.
In theory this approach should work with only the nvidia-driver/docker/nvidia-docker installed on the machine. So I guess there is some incompatibility, with the 430.40 driver.

https://www.pugetsystems.com/labs/hpc/2-x-RTX2070-Super-with-NVLINK-TensorFlow-Performance-Comparison-1551/

I saw this website and it seems that the official tensorflow docker container works for him.
The system configuration in the website is:
Ubuntu 18.04
NVIDIA display driver 430.40 (from Graphics-Drivers ppa)
Docker 19.03.0-ce
NVIDIA-Container-Toolkit 1.0
NVIDIA NGC container registry
Container image: nvcr.io/nvidia/tensorflow:19.02-py3 for “Big LSTM” and “CNN”

(ps:I also had a rtx 2070 Super card, but I’m new to setting the environment. I will try to install tensorflow in a few days.)

Edit: Using docker and the container image above, it works for me.

I’ve got same issues with RTX 2070 Super like in first message of this post. When install drivers from NVIDIA site TF-2.0 does not see GPU. When install drivers from TF site instruction (https://www.tensorflow.org/install/gpu or from PPA repository) get black screen on system loading. And in docker latest-gpu-jupyter GPU still does not work. Installed driver 340.50. CUDA 10.1.

EDIT:

I repaired black screen by follow (https://devtalk.nvidia.com/default/topic/1050968/nvidia-smi-quot-no-devices-were-found-quot-ubuntu-18-04/)

I tried two CUDA samples like recommended in installation guide deviceQuery and bandwidthTest, both were passes. (https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#runfile-installer-ui)

EDIT2:

Solved problem.
Just uninstall CUDA 10.1 and install CUDA 10.0 how says in TF install guide https://www.tensorflow.org/install/gpu. Add to .bashrc PATH varibales
export PATH=/usr/local/cuda-10.0/bin${PATH:+:{PATH}} export LD_LIBRARY_PATH=/usr/local/cuda-10.0/lib64\ {LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
REOPEN console and run jupyter notebook. All fine!

I was running into that problem when trying to train a NN on my new RTX 2070 Super. Came across a post that recommended adding the below lines to my notebook and everything ran fine.

from tensorflow.compat.v1 import ConfigProto
from tensorflow.compat.v1 import InteractiveSession

config = ConfigProto()
config.gpu_options.allow_growth = True
session = InteractiveSession(config=config)

Hello,

Were you guys successful with the tensorflow installation? I’ve been having a hard time installing tensorflow with RTX 2070 SUPER gpu. I am trying the installation with the following:

GPU: RTX 2070 SUPER

Operating System & Version: Ubuntu 18.04.03 LTS

GPU Drivers: nvidia-driver-430

Tensorflow Version: tensorflow-gpu==1.14

Any help would be greatly appreciated!

Hiya folks, just chiming in with my experience. I managed to set it up with the following system:

OS: Windows 10
CPU: Ryzen 7 3800X
GPU: RTX 2070 SUPER

tensorflow-gpu 1.4.0
Python 3.6 (!)
CUDA v8.0 (!)
cuDNN v6.0 (!)

The last three items caused me the most grief, but trust me. The effort pays off.

I’ve got this implementation https://github.com/ibab/tensorflow-wavenet of wavenet training on Debussy solo piano repertoire at 1.3 sec/step and a breezy 62°C (for reference, my 2015 macbook chugs away on the same task over an order of magnitude slower at 40 sec/step). Needless to say I am floored. Good luck to all of you.