How to train Keras models on Jetson Nano

Hi,

I am trying to train a single layer dense model (Though I would like to train more complex models later )on nano but not able to do so.

My model is just a single dense layer with 100 output neurons. Though I was able to successfully retrain the other pytorch model using transfer learning.

What I could see as the output of the sudo jtop is:

  1. Most of the memory is used 3.4/4 GB with 1.3/8.0 GB of swap space.
  2. 0% of GPU usage with 7%-8% of either of the four cores of the CPU.

Once I start training the model, after sometime nano gets shutdown !

Thanks

Hi Sirius, I have trained PyTorch model on Nano, but not Keras personally. Have you tried mounting a swap file? Similar to like done here:

https://support.rackspace.com/how-to/create-a-linux-swap-file/

Also, which power supply are you using? Have you tried a 4A DC barrel jack adapter?

Hi dusty_nv,

Yes I did created a 8GB swap space on a 32 GB thumb drive using fallocate as mentioned in the https://support.rackspace.com/how-to/create-a-linux-swap-file/ .

Though currently the board is powered with 5V==2A Micro USB (Raspberry Pi) power adapter. Till now I didn’t tried 5V==4A barrel jack adapter.