How to use UART on Tegra TX1?

Hi,

I need to communicate with another module(Roboclaw Motor Driver) from the Tegra TX1 through UART. The TX1 and the module both communicate at 3.3V.

Things I have tried:
1.) I tried connecting to UART1 on the TX1(pins 8 and 10 on J21) and used “/dev/ttyS0” but couldn’t communicate.
2.) Anytime I used “/dev/ttyTHS1”, the board hangs. (even when I used “setserial” to get info on the same)
3.) I couldn’t find where the other two UART pins are on the TX1.

Can someone please let me know how to set up a basic UART communication on the TX1 and the linux ports ids.
(I have done this successfully on the TK1, but not really sure how to do it on the TX1.)


LPT JetPack 3.1, Ubuntu Xenial, Tegra TX1

ttyS0 is the serial console. J17 has “/dev/ttyTHS2” and also runs to the camera (if you don’t use the serial port on the camera this will “just work”).

Thanks linuxdev.

It worked out. :D

A follow up question, I need another UART port. I know the board has three UART ports, but how do i access the other two?(physical pins)

UART 0 is the serial console.
UART 1 is on J17 (currently the one i am using)
UART 2 is on J18, the M2.key connector for SSD.

J21 is of course serial console ttyS0, J17 the 6-pin ttyTHS2. As for the other UARTs I’m not sure. I see that there are two going to the J10 debug header, but I’m not sure if this has some other or if the UART is free to use. For example, it seems UART4 is listed as “reserved” on the actual module. Another UART goes to the audio (APE), but I doubt this is acessible even if you were to disable it from audio.

Can anyone at NVIDIA suggest if the J10 debug UARTs are available for general use?

One thing you might consider are USB serial UARTs if you need more (in which case I’d stick to FTDI UARTs).

Got it.
Thank you for your quick reply.

Access to /dev/ttyTHS1 leds to system complete hung is due to recent DTB changes in kernel sources for Jetson JetPack 3.1
See https://devtalk.nvidia.com/default/topic/1023121/?comment=5205888

ttyTHS2 goes to J17. Not sure where ttyTHS1 goes.