HUB connected to USB type-C not giving full bandwidth (10 Gbps) while using camera

I tried connecting a HUB USB Gen 2 USB type-C to Type-C port (10Gbps) in Jetson AGX Orin 64 GB. Single camera connected to HUB is able to stream 60 FPS , but once I connect second one, both camera FPS reduces to 38, and I add 3rd one then It again reduces to 26 FPS for all three cameras. Each camera is streaming 1280x2160x3, 60 FPS video. Total video size at HUB is 3840x2160x3, 60 FPS. Color format is YUV2.
Same hardware set-up is tested with intel based Laptop (using i7 11th gen), and there I am able to get 60 FPS with the 3 camera connected to hub.
Is there any solution to get full 10 Gbps bandwidth? should I update any driver?
Same issue i am getting with AMD Ryzen 9 5900HX based PC.
Jetson AGX Orin info: 32 GB RAM
Jetpack 5.1.1 updated on 29th Mar 2023
Ubuntu 20.04

R 35.3.1

Unlock all 12 CPU and running on full clock (unlocked performance)
I tried accessing camera using python, and ffmpeg. Both are giving same result.

Could you try this suggestion:
USB Port bandwidth limitation - #8 by DaneLLL

It is possible performance drops if multiple devices are connected to single roothub. The performance may drop due to concurrent access.

I tried.
So I think only Intel CPU with 11th gen and above can handle simultaneously transfer more than 1 USB up to 10 Gbps in total data.
I tested same hardware setup with AMD based laptop, M1 Macbook pro, Jetson AGX Orin, all three are reducung FPS when connecting more than 1 USB camera.
Can someone explain why this is happening? What hardware is limiting this?


Hi Ankit,

I believe it’s the Root End-point limitation in Jetson AGX. Each root hub is limited to 10 Gbps USB 3 Gen2 SS+ OR 5 Gbps USB 3 Gen2 SS. So if your devices (cameras) are streaming at 5 Gbps, the root hub is not going to upsample the datarate to 10 Gbps. Your maximum bandwidth will remain 5 Gbps. As far as I know, nearly all available USB3 cameras USB3 Gen1 (5Gbps) devices and not Gen2 (10 Gbps). It’s all about the root hub’s upstream bandwidth limitation. Now, in the Xavier AGX, Nvidia’s documentation clearly states that 2 PHY ports (port0 and port3) share one 10 Gbps bandwidth and another PHY port (port 2) shares another 10 Gbps. But whether this holds true for the Orin AGX as well, I am not so sure about that. You will need to check the Datasheet.

Hi Ankit,

A quick update. Please refer to the technical reference manual of AGX Orin. It clearly states that port 0 and port 1 share 10 Gbps bandwidth and port 2 and port 3 share another 10 Gbps bandwidth. This is a xHCI controller limitation on the AGX Orin/Xavier. The reason this works with your Intel Gen 11 laptop, is that Intel probably has multiple xHCI controllers built into their processor. Hope this helps

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.