USB Port bandwidth limitation

Although Jetson AGX Orin has USB 3.2 port and can support upto 10Gbps bandwith, In my use case where I have connected 3 USB (each 5 Gbps) and sending data ~< 10 Gbps, I am not able to get 10Gbps bandwidth for all three instances together.
Is this hardware limitation? or can be updated using driver update?
In intel laptop with the same USB 3.2 port I am able to get ~10 Gbps with the same hardware setup.

Welcome to the NVIDIA developer community @ankit.kumar2!

I move your post to the Jetson categories, I think there you will more easily get some input on this.


1 Like

Do you observe the issue on Orin developer kit or your own custom board? And the latest release is Jetpack 5.1. If you use previous version, please upgrade and give it a try.

Yes, This issue is with Orin developer kit only and It has Jetpack 5.1. I tried to re-flash it as well with the latest driver files as well.

We have the JetPAck 5.1.1 release by today, please help to get it a try. Thanks

I have updated the Jetpack to 5.1.1, and still same issue is there. USB HUB is being recognized as “new SuperSpeedPlus Gen 2 USB device number 40 using tegra-xusb” .
I am streaming a video but not getting the real time video FPS (60). FPS are limited to 28 only. I tried USB - C port as well as USB - A port, but result FPS are 28 max.

This is driver issue or hardware (Jetson AGX Orin 64 GB development board) limitation?

Video frame size is 4K at HUB. And I am using opencv to read video frames.

Please try to connect some cameras to the type C ports and give it a try. The type-A ports use one USB3 roothub and performance may drop due to concurrent access of multiple devices. Would suggest connect to the type C ports to use other roothubs

I tried with Type-C port (10Gbps) in Jetson AGX Orin 64 GB. Single camera connected to USB Gen 2 HUB is able to stream 60 FPS , but once I connect second one, both camera FPS reduces to 38, and I add 3rd one then It again reduces to 26 FPS for all three cameras. Each camera is streaming 1280x2160x3, 60 FPS video. Total video size at HUB is 3840x2160x3, 60 FPS. Color format is YUV2.
Same hardware set-up is tested with intel based Laptop (using i7 11th gen), and there I am able to get 60 FPS with the 3 camera connected to hub.
Is there anything I should do? like driver update?
Same issue i am getting with AMD Ryzen 9 5900HX based PC.