I can't debug CUDA with VC 2005

http://forums.nvidia.com/index.php?showtopic=30273

Recently I followed this article to add the cuda.rules…
and then I can’t stop the program at the breakpoint …
Before adding the rules , I didn’t change any VC enviroment parameters
and it could be interrupted…

what’s wrong with my VC 2005?
please~help me~~ :no:

You might try the VS2005 wizard from this thread instead of just the build rule:
http://forums.nvidia.com/index.php?showtopic=65111

Also, remember you can only debug in the emulation compile mode. The code must run on the CPU to debug it, there’s no debug support for code really running on GPU.

hello~Big_Mac

I have installed the “VS2005 Project Wizard for CUDA” you supported…
and I used it to create a new project…
But I still can not debug on EmuRelease or EmuDebug…

In VS environment , about the option “Custom Build Rules”
I can find 2 CUDA options :

  1. path : VCProjectDefaults\cuda.rules (kyzhao supported I think…)
  2. path : NVIDIA CUDA SDK\common\scripts\nvcc.rules
    (CUDA SDK supported)

(1)
when I enable cuda.rules to compile…
The VS couldn’t compile all instruction about CUDA
and couldn’t find the “cutil.h”…

(2)when I enable cuda.rules to compile…
The VS “can” compile the cu file…but EmuRelease or EmuDebug is
still useless

How can I set my VS 2005 environment parameters and
make it normal…

Please Help me…

Generally,I always copy the project"template" in the SDK to your file to make your own project just by modifing the template code.
Try this and good luck.