I forgot the user password of Xavier

Hello everyone. as I mentioned on the top, I forgot the user password.

as you know, It was originally ‘nvidia’ and I changed it one-time several weeks ago.

This is all my fault but I desperately need this machine.

the only thing I can do is just watching the log-in section which I cannot pass through.

Do you know how to re-initialize Xavier or reinitialize the user password?

In previous releases there was both a user “nvidia” and “ubuntu”. The default password of “ubuntu” is “ubuntu”, and for “nvidia” is “nvidia”. Are both of those changed?

If you are not worried about losing content, then you could just flash with the most recent release. If you need to save content, then you should clone the rootfs (takes significant time and disk space) first. A few options are available once you have the clone. Cloning instructions may differ depending on release. Do you need to clone, and if so, which release are you using?

Hi, linuxdev

First of all, I don’t care about losing my contents, I have another backup and all I want is just the performance based on Xavier.

Currently I can not access to the account ‘ubuntu’. I know it sounds strange, but I did all I could do but it is not possible to access through the account ‘ubuntu’.

I used a host computer Ubuntu 18.04 LTS installed on VMWare on windows 10. Do you think this virtual machine can be a problem??

The release verison I used to activate Xavier is 4.1.1.deb, not 4.1.2 installer. (At that time, it was the latest version to activate Xavier.)

The other problem I got is that whenever I run 4.1.1.deb, while installing necessary packages, there is always an error “ /bin/bash: No such file or directory”.

Later I tried also 4.1.2 installer but the same error message is returned.

I’ve tried to re-launch 4.1.1.deb but I got this error message every single time!! It always returns me this error message.

I don’t think this is a problem of Xavier, because whenever I’ve launched 4.1.1.deb or 4.1.2 SDK,the Xavier was disconnected.

I am still fixing this problem but this another problem frustrates me.

Anyway, thanks a lot for your comment. I do thank you.

Best regards,

If you don’t care about loss, then definitely a new flash would be the easiest way to go. The most recent JetPack/SDK Manager4.2 does not install the account until first boot though, so for that release you do have to log in once at the GUI of the Xavier to add the initial account.

VMs are not supported, they usually error out when USB connects and reconnects…the VM loses the USB. You can make it work if you can dedicate that USB device to the VM. There may be a similar difficulty in setting up ethernet for the extra packages step after the flash completes…there is a virtual ethernet device on the USB-C of the Xavier after a flash and reboot. There are alternate methods to work with ethernet, but it isn’t worth talking about until the flash step is complete. Overall I think the next step is to find the VM settings which dedicates the recovery mode Xavier to the VM regardless of how many times it disconnects and reconnects. Or switch to dual boot.

1 Like

you guys know any tutorial for this? having trouble flashing not sure if its the SDK host or the AGX any help would be appreciated!

Tutorial for what? Password recovery? Flashing?

Btw, I like your avatar, reminds me of Star Citizen, trying to drink through the helmet…

1 Like

haha thanks, and preferably the password recovery route for ubuntu so i don’t lose data but i tried jetsonhacks and just need to setup the vm right and waiting for a rj45;| if not then ill flash it and start over lol.

typically for ubuntu password recovery booting with an argument init 1 can be used, but it is not the case for the Jetson ecosystem;

One option is to clone the rootfs, edit passwords on the host PC (either QEMU commands to change the password while logged in as root on the PC, or directly editing the clone files), and then reinstalling based on the clone. If you flash a clone you would need to be sure the L4T/JetPack/SDK Manager release is the same as that of the clone.

Either way, if you wish to save your content, you will need to clone first (lots of host PC disk space required, and time consuming). What you would end up doing is mounting the raw clone (cloning provides both a sparse “.img” file and a raw “.img.raw” file), and doing the equivalent to the script found here:
https://forums.developer.nvidia.com/t/jetson-nano-all-usb-ports-suddenly-stopped-working/75784/37

That script is designed to add name/pass to an unconfigured rootfs, and you would need to slightly modify this to instead set a password without creating the account (or you would need to first remove the accounts via editor).

NOTE: VMs tend to fail since they rarely handle the constant USB disconnect/reconnect which occurs during a flash.

to make a raw dd image as @linuxdev mentioned will provide broad opportunities e.g. to mount the disk image as a loopback. After that the filesystem can be accessed, files retrieved, probably it might be even possible to enter into the tegra ubuntu using the method applied in case of recovering ubuntu password from livecd sudo chroot /mnt
reference: https://help.ubuntu.com/community/LiveCdRecovery
I did not try the chroot method with tegra, but with regular stock ubuntu. However, there are some odds that it might work.
After [if] the password got changed it will likely be possible to write the modified raw disk image back to the Jetson device with dd

1 Like

The only issue you might have with a CD/DVD live distribution is if the host o/s tries to use the 64-bit ARM files after the chroot. Even if this fails though, the effort to try is minimal. If one adds QEMU to a live distribution things get interesting (in a good way) if it succeeds.