Password Lock

After rebooting for installing the latest software update the unlocking of the login keyring does no longer work. Error message “the unlock password was incorrect” How do I reset the password to my Jetson Xavier without the current or original password?

Password bypass is not something which was intended (it wouldn’t be much of a password if it were that simple). If passwords are wrong, and you don’t need what is on the Jetson, then it is far simpler to just flash and start over.

If what is on the board is valuable, then you could clone the Jetson (lots of time and disk space), repair the clone on loopback on the host PC, and then flash the clone back in.

What’s more concerning is that the current password was altered. Was this on a secure network? Was the password strong? Are you also unable to log in via serial console? Is there any unusual message other than the password failing (sudo could generate extra messages)?

Thanks for your reply. I tried to enter the admin password that I remember, but any attempt failed. Maybe I used a cap, maybe not, maybe I added a special character maybe not.
Could you please provide the steps I would need to follow to 1/ repair the clone on loopback on the host and flash back the clone 2/ explain how to login via serial console – I am new to jetson xavier and am not used to work on Windows. There are no unusual message except that authentication was unsuccessful. Thanks for your help.

Oh the other message I get is that “the login keyring did not get unlocked when you logged into your computer”

I don’t know much about this, but it seems this may be related to auto login. Was this ever set for auto login?

If it is an auto login issue, then cloning would produce an image to work on, but I’m not sure you’d be able to edit the right thing directly from the clone image. More likely, if you want to save data, then you’d clone, flash normally, and then copy the clone content back in as needed, e.g., for “/home” or “/usr/local”.

When you do clone with an R32.x release, basically the Jetson is connected to the Linux host PC while in recovery mode, and then you issue the following command (I am assuming a dev kit, eMMC modules would be a bit different):
sudo ./ -r -k APP -G my_backup.img jetson-xavier-nx-devkit mmcblk0p1

For an eMMC model, you’d change “jetson-xavier-nx-devkit” for “jetson-xavier-nx-devkit-emmc” (or at least I think those are the designations).

The actual directory you must first cd to depends on release. You’ll find the correct location as:

You would need to make sure you have a lot of free disk space on the Linux PC prior to cloning. The entire size of the partition would produce one “raw” clone, the other copy would be the “sparse” clone. The “my_backup.img” is the sparse clone, and the “my_backup.img.raw” is the raw clone. You can throw away the smaller sparse clone, but keep the larger “my_backup.img.raw”…it is the raw version you can loopback mount, examine, and edit. The sparse clone can only be used for flash. The larger raw clone can also be used for flash, it just takes longer to flash than the smaller sparse version.

You might want this clone as a backup even if you choose to flash cleanly.

Note that the Jetson will have a version listed via “head -n 1 /etc/nv_tegra_release”. This is the L4T version. When restoring from a clone you must use the flash software from that same version. Here is a list of JetPack releases, and you’d look for the one which produces that L4T in the flash:

I must again emphasize your PC needs a lot of disk space.

I do not think my Xavier was installed for automatic login because each time I reboot it is asking me for the password.

If I have nothing valuable on this Xavier (or I can easily recreate what I have so far) would I need to clone or can I just start over from scratch?

Could you send me the step by step procedure to restart from scratch?

Thanks for your help.


You would not need to clone in that case (and it would be much faster and simpler to not clone). I’d say to just flash it with the most recent version. This is the NX forum, and I tend to think of “Xavier NX” as “NX”, but just “Xavier” as the more powerful and more expensive Xavier. Assuming this is the NX, then it means you might have either an SD card model (a dev kit), or else an eMMC model (a module type the dev kit does not arrive with).

Is this the NX? If so, is this an SD card model (a dev kit), or is it the eMMC model on a third party carrier board? Instructions vary depending on which type it is.

EDIT: Note that the listing of JetPack/SDKM releases can be found here:

What actually gets flashed is L4T, and each JetPack will show the L4T it flashes. The listing of all L4T releases is here:

My Xavier is an NX with an SD card model.

Please send me step by step instructions on how to restore my Xavier NX with SD card. Thank you.


Here is a listing of JetPack/SDKM releases:

The current most recent release is JetPack/SDKM 4.4.1, which flashes L4T R32.4.4. If you go to that release, then you’ll see a section on “JETSON NANO DEVELOPER KITS”, and within that there is a download for an SD card image. If you are using this pre-canned SD card image, then you could just follow the instructions for that.

Alternatively, you could use the SDKM (also listed on that page) along with an Ubuntu 18.04 PC, and flash via that method (which offers some more options, e.g., some PC side support as well).

Note that if you were to download and run SDKM from an Ubuntu PC, and if that file name is “sdkmanager_1.3.1-7110_amd64.deb” (current as of today), then you would do this on the PC:
sudo dpkg -i sdkmanager_1.3.1-7110_amd64.deb
(from the directory you downloaded the .deb to)

The actual steps (once the .deb is in place) are also provided there.

Many thanks. You probably meant download the image for the Jetson Xavier kit, right?


Yes, the SD card version allows downloading an image which can be flashed directly to the SD card. JetPack/SDKM can be used as well, but this involves more steps.


Just a short note to thank you for helping me to restore my system. While it took me three attempts to flash the SD card, it eventually worked after I first formatted the SD card ( I presume that the earlier attempts just added another copy of the flash and hence when put in the Xavier I did not get a boot). However now all is well and I can get back programming the Xavier. Thank you.