I have problem in my nvc after update

I am completely new to the Ubuntu operating system. It appears that there are updates that I accepted and the program no longer works and I could not solve the problem.

pgc++ -fast -acc -Minfo=accel -gpu=cc86 my_file.cpp  -g -o p66

pgc++-Error-A CUDA toolkit matching the current driver version (0) or a supported older version (11.1) was not installed with this HPC SDK.

I wanted to check the current version, so I tried the following instruction

nvcc --version
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2021 NVIDIA Corporation
Built on Thu_Nov_18_09:45:30_PST_2021
Cuda compilation tools, release 11.5, V11.5.119
Build cuda_11.5.r11.5/compiler.30672275_0

As I understood it, it was updated, so I used to modify it, to no avail

sudo apt-get -o Dpkg::Options::="--force-overwrite" install cuda-11-1 cuda-drivers

please if there is any update to environment tell me how to do it
or CUDA_HOME variable, I dont know how to change it

Looks to be a problem with your CUDA Driver, not the CUDA SDK installation. The driver seems to be returning that it’s version is “0”.

What’s the output from the command “nvidia-smi”?

Could your installation have installed the Nouveau drivers instead? Nouveau is a the open source CUDA driver but doesn’t support compute on the devices, only graphics.

To check, run “lsmod | grep nouveau”.

If this is the case, then you’ll want to install the NVIDIA CUDA Drivers from: Official Drivers | NVIDIA

1 Like

Yes there was aproblem in upgrade. After I try many wayes ti solve it , I format my computer and the problem solved. Thank you so much