I used the origin system of 35.2.1,the system crashed when booting

I downloaded the Tegra_Linux_Sample-Root-Filesystem_R35.2.1_aarch64.tbz2 and Jetson_Linux_R35.2.1_aarch64.tbz2.
Then I executed sudo ./apply_binaries.sh in directory Linux_for_Tegra.
Then, I run sudo ./flash.sh jetson-xavier-nx-devkit-emmc internal to burn Xavier NX.
Last, I boot the system,and after booting succussfully 4 times, the Xavier NX crashed.
The attachment is the crash log.
nx_crash.txt (58.1 KB)

Could you please tell me how to solve the crash problem?

Please try to flash the device through SDKManager and check if the issue is still observed.


It is a known issue from display.

Is it solved?If yes, please tell me.

no, we only have workaround.

diff --git a/drivers/video/tegra/dc/dc.c b/drivers/video/tegra/dc/dc.c
index 1cedba9..09e1a0d 100644
--- a/drivers/video/tegra/dc/dc.c
+++ b/drivers/video/tegra/dc/dc.c
@@ -6374,7 +6374,7 @@
 		pr_debug("dc->fb_mem not initialized\n");
 		return false;
-	return (dc->fb_mem->start != 0);
+	return false;

I test 20 times after modifing the code, the board all can boot correctly.But there is one times of crash when input sudo reboot.The attachment is the log of crash.Do you have idea to solve it?
reboot_crash.txt (4.0 KB)

That issue is not related to display. Should be related to ethernet. No solution yet.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.