I2s cann't output

I worked on a change from jetson tx2 to rt5651.
When playing a wav file, mclk is output. However, i2s is not output.
Please refer to the device tree file.
custom.out (499.4 KB)

Please check if can find some suggestions from Search: trouble (nvidia.com)

Search: trouble (nvidia.com) le saw.
However, I did not get a hint about the i2s output.
pinctrl is as follows.
pinmux is as follows.
cat /sys/kernel/debug/tegra_gpio
Can you tell me why i2s output is not working?

Hi Sangjina,

In the DT attched, see that multiple codecs are added for same address 0x1a under i2c@c240000. Please add rt5651 and remove other codec entries(rt5659 here). Refer link for guidance on integrating new codec on 40 pin header

For pinmux setting, confirm if you have followed method from link (note current setting seem fine but use documented method to avoid issues)

Also, refer link for reference on audio routes to be added in DT and mixer settings to be made via terminal.

Do provide information on

  1. If codec is registered after trying above

  2. If sound card is registered

Further troubleshooting guide is available at link and “Sound Not Audible or Not Recorded” mentions the relevant attachments to be made on forum post in case of further issues


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.